Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1064236 - Met errors when sending emails after user applyed to powered by partner.
Summary: Met errors when sending emails after user applyed to powered by partner.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Online
Classification: Red Hat
Component: Website
Version: 2.x
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: ---
Assignee: David Morrison
QA Contact: libra bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-12 09:43 UTC by Yujie Zhang
Modified: 2015-05-15 01:32 UTC (History)
3 users (show)

Fixed In Version: https://github.com/openshift/li/pull/2502
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-04-09 15:18:16 UTC


Attachments (Terms of Use)

Description Yujie Zhang 2014-02-12 09:43:22 UTC
Description of problem:

Applyed to be powered by partner with valid content, check the log of send emails, found there are the following error:

212  12/Feb 04:22  info   devel    Mail sent:Id: openshift_partner_program_openshift_partner_program_apply_poweredby_info_submitted_userTo: yujzhang+dev0212518@redhat.comFrom: noreply@redhat.comLanguage: Subject: Thank you  
 213  12/Feb 04:22  info   devel    Mail sent:Id: openshift_partner_program_openshift_partner_program_apply_poweredby_infoTo: openshift-partners@redhat.comFrom: noreply@redhat.comLanguage: Subject: ACTION NEEDED: test test h 
 214  12/Feb 04:22  error  php      Illegal offset type in isset or empty in /usr/share/drupal6/includes/bootstrap.inc on line 997. 
 215  12/Feb 04:22  error  php      Illegal offset type in /usr/share/drupal6/includes/bootstrap.inc on line 998. 
 216  12/Feb 04:22  error  php      Illegal offset type in /usr/share/drupal6/includes/bootstrap.inc on line 1002. 
 217  12/Feb 04:22  error  imagecache  404: Unable to find                         
 218  12/Feb 04:22  warning  page not found  sites/default/files/badges/badge-newbie.png 
 219  12/Feb 04:22  error  imagecache  404: Unable to find                         
 220  12/Feb 04:22  error  imagecache  404: Unable to find  


Version-Release number of selected component (if applicable):
devenv_4364

How reproducible:
always

Steps to Reproduce:
1.Login to communtiy and go to /partner/powered-by/apply page
2.Input valid content and submit
3.Check the log of send emails by the following commands:

cd /usr/share/drupal6/
drush ws --tail

Actual results:

There are errors when sending emails.

Expected results:

Emails should be sent successfully without error.

Additional info:

Comment 1 Jessica Forrester 2014-02-12 13:45:09 UTC
Imagecache errors are expected in devenvs since we do not export uploaded images from prod.  For the Illegal offset errors, those would not be failures during the email send.  It is possible they occur when the partner portal is loading for the first time, needs investigation.

Comment 2 David Morrison 2014-02-13 18:38:19 UTC
Does not seem to be a blocker bug. From a users perspective everything is working normally.

Current diagnosis:

PHP errors do not occur on partner/portal page load. They only occur once the form has been filled out.

Navigated to /partner/powered-by/apply and filled out the form as user "foo". The drupal msg showed a success. Then on the same devenv I created a new user "bar" and filled out the /partner/powered-by/apply form again with the same results.

 Attempt #1
 --------------------------------------------
 68  12/Feb 10:08  php       error     Illegal offset type in /usr/share/drupal6/includes/bootstrap.inc on line 1002.
 67  12/Feb 10:08  php       error     Illegal offset type in /usr/share/drupal6/includes/bootstrap.inc on line 998.
 66  12/Feb 10:08  php       error     Illegal offset type in isset or empty in /usr/share/drupal6/includes/bootstrap.inc on line 997.
 65  12/Feb 10:08  devel     info      Mail sent:Id: openshift_partner_program_openshift_partner_program_apply_poweredby_infoTo: openshift-partners@redhat.comFrom:
                                         noreply@redhat.comLanguage: Subject: ACTION NEEDED: foo foo has
 64  12/Feb 10:08  devel     info      Mail sent:Id: openshift_partner_program_openshift_partner_program_apply_poweredby_info_submitted_userTo: shalompisteuo@gmail.comFrom:
                                         noreply@redhat.comLanguage: Subject: Thank you for app
 63  12/Feb 10:08  user      notice    Session opened for foo.
 --------------------------------------------

 Attempt #2
 --------------------------------------------
 87  12/Feb 10:12  php       error     Illegal offset type in /usr/share/drupal6/includes/bootstrap.inc on line 1002.
 86  12/Feb 10:12  php       error     Illegal offset type in /usr/share/drupal6/includes/bootstrap.inc on line 998.
 85  12/Feb 10:12  php       error     Illegal offset type in isset or empty in /usr/share/drupal6/includes/bootstrap.inc on line 997.
 84  12/Feb 10:12  devel     info      Mail sent:Id: openshift_partner_program_openshift_partner_program_apply_poweredby_infoTo: openshift-partners@redhat.comFrom:
                                         noreply@redhat.comLanguage: Subject: ACTION NEEDED: bar bar has
 83  12/Feb 10:12  devel     info      Mail sent:Id: openshift_partner_program_openshift_partner_program_apply_poweredby_info_submitted_userTo:
                                         a_made_up_email@mailinator.comFrom: noreply@redhat.comLanguage: Subject: Thank you
 82  12/Feb 10:12  user      notice    Session opened for bar.
 --------------------------------------------

Comment 3 David Morrison 2014-03-21 21:56:36 UTC
Issue fixed in
https://github.com/openshift/li/pull/2502

Comment 4 Yujie Zhang 2014-03-24 07:21:24 UTC
Tested on devenv_4562, no above error after apply to powered by partner, so verify this bug, thanks.


Note You need to log in before you can comment on or make changes to this bug.