Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1064225 - java.lang.NoClassDefFoundError: javax/net/ssl/X509TrustManager
Summary: java.lang.NoClassDefFoundError: javax/net/ssl/X509TrustManager
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss BRMS Platform 6
Classification: Retired
Component: Business Central
Version: unspecified
Hardware: Unspecified
OS: Unspecified
urgent
high
Target Milestone: ER2
: 6.0.1
Assignee: Jan
QA Contact: Lukáš Petrovický
URL:
Whiteboard:
Depends On: 1064223
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-12 09:23 UTC by Ryan Zhang
Modified: 2014-08-06 19:59 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 1064223
Environment:
Last Closed: 2014-08-06 19:59:02 UTC
Type: Bug


Attachments (Terms of Use)

Description Ryan Zhang 2014-02-12 09:23:16 UTC
+++ This bug was initially created as a clone of Bug #1064223 +++

Description of problem:
The error is happening when I start up BPMS or BRMS 6.0.1 ER1 server on EAP 6.1.1 for the first time (upstream tag: sync.2014.02.10).

When I restart the server, the error seems not appear during the server bootstrap.
However if I try to log into business-central web console, I would get this error again both in the server.log and in browser.
Both the server.log and screenshot are attached.

Stacktrace:
14:43:40,581 WARN  [org.jboss.modules] (pool-18-thread-1) Failed to define class org.apache.maven.wagon.shared.http.EasyX509TrustManager in Module "org.apache.maven.wagon:main" from local module loader @561f72d0 (finder: local module finder @2aaae1dc (roots: /workspace/ip/bpms-brms/bpms/target/jboss-eap-6.1/modules,/workspace/ip/bpms-brms/bpms/target/jboss-eap-6.1/modules/system/layers/bpms,/workspace/ip/bpms-brms/bpms/target/jboss-eap-6.1/modules/system/layers/base)): java.lang.LinkageError: Failed to link org/apache/maven/wagon/shared/http/EasyX509TrustManager (Module "org.apache.maven.wagon:main" from local module loader @561f72d0 (finder: local module finder @2aaae1dc (roots: /workspace/ip/bpms-brms/bpms/target/jboss-eap-6.1/modules,/workspace/ip/bpms-brms/bpms/target/jboss-eap-6.1/modules/system/layers/bpms,/workspace/ip/bpms-brms/bpms/target/jboss-eap-6.1/modules/system/layers/base)))
	at org.jboss.modules.ModuleClassLoader.defineClass(ModuleClassLoader.java:427) [jboss-modules.jar:1.2.2.Final-redhat-1]
	at org.jboss.modules.ModuleClassLoader.loadClassLocal(ModuleClassLoader.java:260) [jboss-modules.jar:1.2.2.Final-redhat-1]
	at org.jboss.modules.ModuleClassLoader$1.loadClassLocal(ModuleClassLoader.java:75) [jboss-modules.jar:1.2.2.Final-redhat-1]
	at org.jboss.modules.Module.loadModuleClass(Module.java:526) [jboss-modules.jar:1.2.2.Final-redhat-1]
	at org.jboss.modules.ModuleClassLoader.findClass(ModuleClassLoader.java:188) [jboss-modules.jar:1.2.2.Final-redhat-1]
	at org.jboss.modules.ConcurrentClassLoader.performLoadClassUnchecked(ConcurrentClassLoader.java:444) [jboss-modules.jar:1.2.2.Final-redhat-1]
	at org.jboss.modules.ConcurrentClassLoader.performLoadClassChecked(ConcurrentClassLoader.java:432) [jboss-modules.jar:1.2.2.Final-redhat-1]
	at org.jboss.modules.ConcurrentClassLoader.performLoadClass(ConcurrentClassLoader.java:374) [jboss-modules.jar:1.2.2.Final-redhat-1]
	at org.jboss.modules.ConcurrentClassLoader.loadClass(ConcurrentClassLoader.java:119) [jboss-modules.jar:1.2.2.Final-redhat-1]
	at org.apache.maven.wagon.shared.http.AbstractHttpClientWagon.<clinit>(AbstractHttpClientWagon.java:300) [wagon-http-shared4-2.0.jar:2.0]
	at org.kie.scanner.Aether$ManualWagonProvider.lookup(Aether.java:136) [kie-ci-6.0.2-redhat-3.jar:6.0.2-redhat-3]
	at org.sonatype.aether.connector.wagon.WagonRepositoryConnector.lookupWagon(WagonRepositoryConnector.java:282) [aether-connector-wagon-1.13.1.jar:]
	at org.sonatype.aether.connector.wagon.WagonRepositoryConnector.<init>(WagonRepositoryConnector.java:154) [aether-connector-wagon-1.13.1.jar:]
	at org.sonatype.aether.connector.wagon.WagonRepositoryConnectorFactory.newInstance(WagonRepositoryConnectorFactory.java:142) [aether-connector-wagon-1.13.1.jar:]
	at org.sonatype.aether.impl.internal.DefaultRemoteRepositoryManager.getRepositoryConnector(DefaultRemoteRepositoryManager.java:346) [aether-impl-1.13.1.jar:]
	at org.sonatype.aether.impl.internal.DefaultMetadataResolver$ResolveTask.run(DefaultMetadataResolver.java:559) [aether-impl-1.13.1.jar:]
	at org.sonatype.aether.util.concurrency.RunnableErrorForwarder$1.run(RunnableErrorForwarder.java:60) [aether-util-1.13.1.jar:]
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145) [rt.jar:1.7.0_51]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615) [rt.jar:1.7.0_51]
	at java.lang.Thread.run(Thread.java:744) [rt.jar:1.7.0_51]
Caused by: java.lang.NoClassDefFoundError: javax/net/ssl/X509TrustManager
	at java.lang.ClassLoader.defineClass1(Native Method) [rt.jar:1.7.0_51]
	at java.lang.ClassLoader.defineClass(ClassLoader.java:800) [rt.jar:1.7.0_51]
	at org.jboss.modules.ModuleClassLoader.doDefineOrLoadClass(ModuleClassLoader.java:344) [jboss-modules.jar:1.2.2.Final-redhat-1]
	at org.jboss.modules.ModuleClassLoader.defineClass(ModuleClassLoader.java:422) [jboss-modules.jar:1.2.2.Final-redhat-1]
	... 19 more
Caused by: java.lang.ClassNotFoundException: javax.net.ssl.X509TrustManager from [Module "org.apache.maven.wagon:main" from local module loader @561f72d0 (finder: local module finder @2aaae1dc (roots: /workspace/ip/bpms-brms/bpms/target/jboss-eap-6.1/modules,/workspace/ip/bpms-brms/bpms/target/jboss-eap-6.1/modules/system/layers/bpms,/workspace/ip/bpms-brms/bpms/target/jboss-eap-6.1/modules/system/layers/base))]
	at org.jboss.modules.ModuleClassLoader.findClass(ModuleClassLoader.java:196) [jboss-modules.jar:1.2.2.Final-redhat-1]
	at org.jboss.modules.ConcurrentClassLoader.performLoadClassUnchecked(ConcurrentClassLoader.java:444) [jboss-modules.jar:1.2.2.Final-redhat-1]
	at org.jboss.modules.ConcurrentClassLoader.performLoadClassChecked(ConcurrentClassLoader.java:432) [jboss-modules.jar:1.2.2.Final-redhat-1]
	at org.jboss.modules.ConcurrentClassLoader.performLoadClass(ConcurrentClassLoader.java:374) [jboss-modules.jar:1.2.2.Final-redhat-1]
	at org.jboss.modules.ConcurrentClassLoader.loadClass(ConcurrentClassLoader.java:119) [jboss-modules.jar:1.2.2.Final-redhat-1]
	... 23 more


 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Ryan Zhang on 2014-02-12 04:13:41 EST ---



--- Additional comment from Ryan Zhang on 2014-02-12 04:17:17 EST ---



--- Additional comment from Ryan Zhang on 2014-02-12 04:19:43 EST ---

Since ER1 is still not announced.
The BPMS ER1 can be downloaded at https://jenkins.mw.lab.eng.bos.redhat.com/hudson/view/SOA-Team/view/SOA-CI/job/soa-team-ci-6-ip-bpms/ws/build/bpms-brms/bpms/target/jboss-bpms-6.0.1.GA-redhat-1-deployable-generic-deployable-eap6.x.zip

Please unzip this package into EAP 6.1.1 to reproduce this problem.

Comment 2 Rajesh Rajasekaran 2014-02-12 19:12:54 UTC
Instructions to verify or patch ER1 build.

- Edit <EAP_ROOT>/modules/system/layers/bpms/org/apache/maven/wagon/main/module.xml
    - Add <module name="javax.api" export="false"/>
    - Add <module name="sun.jdk" export="false"/>

- Move mina-core jar from webapp into kie-lib module
  Move mina-core-2.0.0-redhat-3.jar from business-central.war/WEB-INF/lib directory
  to <EAP_ROOT>/modules/system/layers/bpms/org/kie/lib/main/

- Edit <EAP_ROOT>/modules/system/layers/bpms/org/kie/lib/main/module.xml

  Add <resource-root path="mina-core-2.0.0-redhat-3.jar"/>

The same procedure must be applied for BRMS artifacts (layer and WAR) if a similar problem is found.

Comment 5 Lukáš Petrovický 2014-03-13 13:17:12 UTC
I do not see this issue anymore. VERIFIED with ER2.


Note You need to log in before you can comment on or make changes to this bug.