Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1064210 - java.io.IOException: Cannot create directory: .index/
Summary: java.io.IOException: Cannot create directory: .index/
Keywords:
Status: CLOSED DUPLICATE of bug 1064212
Alias: None
Product: JBoss BPMS Platform 6
Classification: Retired
Component: Business Central
Version: unspecified
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: ---
: ---
Assignee: Alexandre Porcelli
QA Contact: Marek Baluch
URL:
Whiteboard:
Depends On:
Blocks: 1064212
TreeView+ depends on / blocked
 
Reported: 2014-02-12 09:04 UTC by Ryan Zhang
Modified: 2014-02-12 17:17 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1064212 (view as bug list)
Environment:
Last Closed: 2014-02-12 17:17:03 UTC
Type: Bug


Attachments (Terms of Use)
server.log (deleted)
2014-02-12 09:06 UTC, Ryan Zhang
no flags Details

Description Ryan Zhang 2014-02-12 09:04:34 UTC
Description of problem:
The error is happening when you start up BPMS or BRMS 6.0.1 ER1 server on EAP 6.1.1 (upstream tag: sync.2014.02.10).

The error would disappear if you restart the server without removing .index/ folder in jboss-eap-6.1/bin .

Server.log will also be attached.
StackTrace:
14:43:38,132 ERROR [org.uberfire.metadata.io.BatchIndex] (Thread-86) Index fails. [@/readme.md]: java.lang.RuntimeException: java.io.IOException: Cannot create directory: /home/rzhang/workspace/ip/bpms-brms/bpms/target/jboss-eap-6.1/bin/.index/repository1
	at org.uberfire.metadata.backend.lucene.index.directory.DirectoryLuceneIndex.<init>(DirectoryLuceneIndex.java:53) [uberfire-metadata-backend-lucene-0.3.2-redhat-3.jar:0.3.2-redhat-3]
	at org.uberfire.metadata.backend.lucene.index.directory.DirectoryType$2.newIndex(DirectoryType.java:63) [uberfire-metadata-backend-lucene-0.3.2-redhat-3.jar:0.3.2-redhat-3]
	at org.uberfire.metadata.backend.lucene.index.directory.DirectoryFactory.newCluster(DirectoryFactory.java:81) [uberfire-metadata-backend-lucene-0.3.2-redhat-3.jar:0.3.2-redhat-3]
	at org.uberfire.metadata.backend.lucene.index.LuceneIndexManager.indexOf(LuceneIndexManager.java:59) [uberfire-metadata-backend-lucene-0.3.2-redhat-3.jar:0.3.2-redhat-3]
	at org.uberfire.metadata.backend.lucene.index.LuceneIndexEngine.index(LuceneIndexEngine.java:90) [uberfire-metadata-backend-lucene-0.3.2-redhat-3.jar:0.3.2-redhat-3]
	at org.uberfire.metadata.io.BatchIndex$3.visitFile(BatchIndex.java:103) [uberfire-metadata-commons-io-0.3.2-redhat-3.jar:0.3.2-redhat-3]
	at org.uberfire.metadata.io.BatchIndex$3.visitFile(BatchIndex.java:88) [uberfire-metadata-commons-io-0.3.2-redhat-3.jar:0.3.2-redhat-3]
	at org.uberfire.java.nio.file.FileTreeWalker.walk(FileTreeWalker.java:63) [uberfire-nio2-api-0.3.2-redhat-3.jar:0.3.2-redhat-3]
	at org.uberfire.java.nio.file.FileTreeWalker.walk(FileTreeWalker.java:85) [uberfire-nio2-api-0.3.2-redhat-3.jar:0.3.2-redhat-3]
	at org.uberfire.java.nio.file.FileTreeWalker.walk(FileTreeWalker.java:44) [uberfire-nio2-api-0.3.2-redhat-3.jar:0.3.2-redhat-3]
	at org.uberfire.java.nio.file.Files.walkFileTree(Files.java:911) [uberfire-nio2-api-0.3.2-redhat-3.jar:0.3.2-redhat-3]
	at org.uberfire.java.nio.file.Files.walkFileTree(Files.java:930) [uberfire-nio2-api-0.3.2-redhat-3.jar:0.3.2-redhat-3]
	at org.uberfire.metadata.io.BatchIndex.run(BatchIndex.java:88) [uberfire-metadata-commons-io-0.3.2-redhat-3.jar:0.3.2-redhat-3]
	at org.uberfire.metadata.io.BatchIndex.run(BatchIndex.java:77) [uberfire-metadata-commons-io-0.3.2-redhat-3.jar:0.3.2-redhat-3]
	at org.uberfire.metadata.io.BatchIndex$1.run(BatchIndex.java:61) [uberfire-metadata-commons-io-0.3.2-redhat-3.jar:0.3.2-redhat-3]
Caused by: java.io.IOException: Cannot create directory: /home/rzhang/workspace/ip/bpms-brms/bpms/target/jboss-eap-6.1/bin/.index/repository1
	at org.apache.lucene.store.NativeFSLock.obtain(NativeFSLockFactory.java:171) [lucene-core-4.0.0.jar:4.0.0 1394950 - rmuir - 2012-10-06 03:00:40]
	at org.apache.lucene.store.Lock.obtain(Lock.java:72) [lucene-core-4.0.0.jar:4.0.0 1394950 - rmuir - 2012-10-06 03:00:40]
	at org.apache.lucene.index.IndexWriter.<init>(IndexWriter.java:602) [lucene-core-4.0.0.jar:4.0.0 1394950 - rmuir - 2012-10-06 03:00:40]
	at org.uberfire.metadata.backend.lucene.index.directory.DirectoryLuceneIndex.<init>(DirectoryLuceneIndex.java:50) [uberfire-metadata-backend-lucene-0.3.2-redhat-3.jar:0.3.2-redhat-3]
	... 14 more


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Ryan Zhang 2014-02-12 09:06:04 UTC
Created attachment 862162 [details]
server.log

Comment 4 Rajesh Rajasekaran 2014-02-12 17:17:03 UTC

*** This bug has been marked as a duplicate of bug 1064212 ***


Note You need to log in before you can comment on or make changes to this bug.