Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1064157 - oo-diagnostics is still using the old iptables.*.rules files
Summary: oo-diagnostics is still using the old iptables.*.rules files
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Online
Classification: Red Hat
Component: Containers
Version: 2.x
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: ---
Assignee: Lokesh Mandvekar
QA Contact: libra bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-12 07:10 UTC by Meng Bo
Modified: 2015-05-14 23:34 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-26 19:12:33 UTC


Attachments (Terms of Use)

Description Meng Bo 2014-02-12 07:10:30 UTC
Description of problem:
# grep "iptables.*.rules" /usr/sbin/oo-diagnostics
         --custom-rules=ipv4:filter:/etc/openshift/iptables.filter.rules
         --custom-rules=ipv4:nat:/etc/openshift/iptables.nat.rules

Since the iptables.*.rules has been moved to /var/lib/openshift/.httpd.d/ by this PR: https://github.com/openshift/origin-server/pull/4720/

Should update the tool to use the new file path.

Version-Release number of selected component (if applicable):
devenv_4363

How reproducible:
always

Steps to Reproduce:
1. Check the oo-diagnostics command
2.
3.

Actual results:
Use the old iptables rules file path.

Expected results:
The command should be up to date.

Additional info:

Comment 1 openshift-github-bot 2014-02-12 16:25:46 UTC
Commit pushed to master at https://github.com/openshift/origin-server

https://github.com/openshift/origin-server/commit/00f81b8495178daf8800bc70aa22d48494b5884b
Bug 1064157 - new filepaths in oo-diagnostics

iptables.*.rules has moved to /var/lib/openshift/.httpd.d .
This commit updates oo-diagnostics with new filepaths.
	modified:   common/bin/oo-diagnostics

Comment 2 Meng Bo 2014-02-13 06:56:07 UTC
Checked on devenv_4369, the oo-diagnostics using the right directory for iptables rules now.

Move bug to verified.


Note You need to log in before you can comment on or make changes to this bug.