Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1064151 - [abrt] recoll: ole.py:434:getSectorIDChain:IndexError: list index out of range
Summary: [abrt] recoll: ole.py:434:getSectorIDChain:IndexError: list index out of range
Keywords:
Status: CLOSED DUPLICATE of bug 1060634
Alias: None
Product: Fedora
Classification: Fedora
Component: recoll
Version: 20
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Terje Røsten
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:a5e69a3a4a5e671d7c5fecf3fd3...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-12 06:31 UTC by Koen
Modified: 2014-05-16 00:57 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-02 07:41:08 UTC


Attachments (Terms of Use)
File: backtrace (deleted)
2014-02-12 06:31 UTC, Koen
no flags Details
File: environ (deleted)
2014-02-12 06:31 UTC, Koen
no flags Details

Description Koen 2014-02-12 06:31:27 UTC
Version-Release number of selected component:
recoll-1.19.11-1.fc20

Additional info:
reporter:       libreport-2.1.12
cmdline:        python2 /usr/share/recoll/filters/ppt-dump.py --no-struct-output --dump-text /tmp/rcltmpftUczgD.pot
executable:     /usr/share/recoll/filters/ppt-dump.py
kernel:         3.12.9-301.fc20.x86_64
runlevel:       N 5
type:           Python
uid:            500

Truncated backtrace:
ole.py:434:getSectorIDChain:IndexError: list index out of range

Traceback (most recent call last):
  File "/usr/share/recoll/filters/ppt-dump.py", line 141, in <module>
    main(sys.argv)
  File "/usr/share/recoll/filters/ppt-dump.py", line 135, in main
    if not dumper.dump():
  File "/usr/share/recoll/filters/ppt-dump.py", line 66, in dump
    strm.printDirectory()
  File "/usr/share/recoll/filters/msodump.zip/src/pptstream.py", line 64, in printDirectory
    obj = self.__getDirectoryObj()
  File "/usr/share/recoll/filters/msodump.zip/src/pptstream.py", line 56, in __getDirectoryObj
    obj = self.header.getDirectory()
  File "/usr/share/recoll/filters/msodump.zip/src/ole.py", line 273, in getDirectory
    chain = self.getSAT().getSectorIDChain(dirID)
  File "/usr/share/recoll/filters/msodump.zip/src/ole.py", line 434, in getSectorIDChain
    if nextID == self.array[nextID]:
IndexError: list index out of range

Local variables in innermost frame:
nextID: 1056964800
initID: 189
self: <ole.SAT object at 0x1295050>
chain: [189, 1056964800]

Comment 1 Koen 2014-02-12 06:31:32 UTC
Created attachment 862124 [details]
File: backtrace

Comment 2 Koen 2014-02-12 06:31:34 UTC
Created attachment 862125 [details]
File: environ

Comment 3 Terje Røsten 2014-03-02 07:41:08 UTC

*** This bug has been marked as a duplicate of bug 1060634 ***


Note You need to log in before you can comment on or make changes to this bug.