Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1064001 - engine: clone vm from snapshot will not clone the template origin
Summary: engine: clone vm from snapshot will not clone the template origin
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-core
Version: unspecified
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
: 3.5.0
Assignee: Tomas Jelinek
QA Contact: Pavel Novotny
URL:
Whiteboard: virt
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-11 18:30 UTC by Dafna Ron
Modified: 2016-02-10 19:50 UTC (History)
6 users (show)

Fixed In Version: ovirt-3.5.0-alpha1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-17 12:31:11 UTC
oVirt Team: Virt


Attachments (Terms of Use)
engine log (deleted)
2014-02-11 18:30 UTC, Dafna Ron
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 26172 master MERGED core: clone VM from snapshot looses the original template Never

Description Dafna Ron 2014-02-11 18:30:48 UTC
Created attachment 861929 [details]
engine log

Description of problem:

The new RFE which lists the template origin in the template field does not show the template origin when we create a vm from a snapshot. 

Version-Release number of selected component (if applicable):

ovirt-engine-backend-3.4.0-0.7.beta2.el6.noarch

How reproducible:

100%

Steps to Reproduce:
1. create a vm as a clone from a template 
2. create a snapshot 
3. clone a vm from the snapshot 

Actual results:

the new vm cloned from snapshot shows Blank template as vm template. 

Expected results:

since a snapshot is a leaf on the original disk which is created from a template I thin that we should have the original template shown 
if not we need to find a new solution mark clone from snapshot vms and not list them as blank template.

Additional info:

Comment 1 Itamar Heim 2014-02-16 08:23:33 UTC
Setting target release to current version for consideration and review. please
do not push non-RFE bugs to an undefined target release to make sure bugs are
reviewed for relevancy, fix, closure, etc.

Comment 2 Sandro Bonazzola 2014-03-04 09:29:34 UTC
This is an automated message.
Re-targeting all non-blocker bugs still open on 3.4.0 to 3.4.1.

Comment 3 Pavel Novotny 2014-08-05 15:09:00 UTC
Verified in ovirt-engine-3.5.0-0.0.master.20140722232058.git8e1babc.el6.noarch (beta2).

Verification steps (following comment 0):
1. Have a VM template 'vm-template'.
2. Create new VM 'original-vm' based on the template as clone/independent.
3. Create a snapshot on 'original-vm'.
4. Clone new VM 'cloned-vm' from the snapshot.
5. Check which template the 'cloned-vm' depends on.

Result:
'cloned-vm' depends on the same template as 'original-vm', i.e., on 'vm-template' as clone/independent.

Comment 4 Sandro Bonazzola 2014-10-17 12:31:11 UTC
oVirt 3.5 has been released and should include the fix for this issue.


Note You need to log in before you can comment on or make changes to this bug.