Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1063941 - UPGRADE_YUM_GROUP should be 'RHEV Manager' otherwise engine-setup won't find YUM group
Summary: UPGRADE_YUM_GROUP should be 'RHEV Manager' otherwise engine-setup won't find ...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: otopi
Classification: oVirt
Component: Plugins.packagers
Version: 1.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: ---
: 1.2.0
Assignee: Alon Bar-Lev
QA Contact: Jiri Belka
URL:
Whiteboard: infra
Depends On:
Blocks: 1053448 1067682 rhev3.4beta 1142926
TreeView+ depends on / blocked
 
Reported: 2014-02-11 16:38 UTC by Jiri Belka
Modified: 2016-02-10 19:33 UTC (History)
13 users (show)

Fixed In Version: av2
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1067682 (view as bug list)
Environment:
Last Closed:
oVirt Team: Infra
alonbl: devel_ack+


Attachments (Terms of Use)
setup logs (deleted)
2014-02-11 16:38 UTC, Jiri Belka
no flags Details
ovirt-engine-setup-20140317130251.log (deleted)
2014-03-17 12:37 UTC, Jiri Belka
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 24342 None None None Never
oVirt gerrit 24344 None None None Never

Description Jiri Belka 2014-02-11 16:38:46 UTC
Created attachment 861879 [details]
setup logs

Description of problem:

Scenario:
- there's newer redhat-support-plugin-rhev and engine-setup should upgrade it. It should called update on RHEVM YUM group, but /usr/share/ovirt-engine/setup/ovirt_engine_setup/constants.py has 'UPGRADE_YUM_GROUP = 'rhevm33' and this YUM group is not found. engine-setup falls back to yum update rhevm style but this does not update redhat-support-plugin-rhev.

sbonazzo@ found that it is problem between 'rhevm33' and 'RHEV Manager' names. Changing UPGRADE_YUM_GROUP to 'RHEV Manager' made engine-setup update the plugin.

17:17 < sbonazzo> jbelka: since we call yum groups update rhevm33
...
17:18 < sbonazzo> jbelka: as I said, it's not called because not found, so fallback on yum update rhevm
...
17:23 < sbonazzo> jbelka: found the bug: it compares group name "RHEV Manager" against its id "rhevm33" :-/

[root@pb-rh33 ~]# egrep 'RHEV Manager|redhat-support-plugin' /var/log/ovirt-engine/setup/ovirt-engine-setup-20140211172614.log                   
2014-02-11 17:26:27 DEBUG otopi.plugins.ovirt_engine_setup.distro-rpm.packages packages.verbose:177 Yum: queue group RHEV Manager for update
2014-02-11 17:26:29 DEBUG otopi.plugins.ovirt_engine_setup.distro-rpm.packages packages.verbose:177 Yum: group RHEV Manager queued
2014-02-11 17:26:29 DEBUG otopi.plugins.ovirt_engine_setup.distro-rpm.packages packages.verbose:177 Yum:     updated    - redhat-support-plugin-rhev-3.3.0-13.el6ev.noarch
2014-02-11 17:26:29 DEBUG otopi.plugins.ovirt_engine_setup.distro-rpm.packages packages.verbose:177 Yum:     update     - redhat-support-plugin-rhev-3.3.0-14.el6ev.noarch
2014-02-11 17:26:29 DEBUG otopi.plugins.ovirt_engine_setup.distro-rpm.packages packages._checkForProductUpdate:240 PACKAGE: [updated] redhat-support-plugin-rhev-3.3.0-13.el6ev.noarch
2014-02-11 17:26:29 DEBUG otopi.plugins.ovirt_engine_setup.distro-rpm.packages packages._checkForProductUpdate:240 PACKAGE: [update] redhat-support-plugin-rhev-3.3.0-14.el6ev.noarch
2014-02-11 17:26:30 DEBUG otopi.plugins.ovirt_engine_setup.distro-rpm.packages packages._checkForProductUpdate:254 dupes: operation [available] package redhat-support-plugin-rhev-3.3.0-14.el6ev.noarch
2014-02-11 17:26:30 DEBUG otopi.plugins.ovirt_engine_setup.distro-rpm.packages packages._checkForProductUpdate:254 dupes: operation [installed] package redhat-support-plugin-rhev-3.3.0-13.el6ev.noarch
2014-02-11 17:26:30 DEBUG otopi.plugins.ovirt_engine_setup.distro-rpm.packages packages._checkForProductUpdate:254 dupes: operation [reinstall_available] package redhat-support-plugin-rhev-3.3.0-13.el6ev.noarch
2014-02-11 17:26:30 DEBUG otopi.plugins.ovirt_engine_setup.distro-rpm.packages packages._checkForProductUpdate:254 dupes: operation [available] package redhat-support-plugin-rhev-3.3.0-14.el6ev.noarch
2014-02-11 17:26:30 DEBUG otopi.plugins.ovirt_engine_setup.distro-rpm.packages packages._checkForProductUpdate:254 dupes: operation [installed] package redhat-support-plugin-rhev-3.3.0-13.el6ev.noarch
2014-02-11 17:26:30 DEBUG otopi.plugins.ovirt_engine_setup.distro-rpm.packages packages._checkForProductUpdate:254 dupes: operation [reinstall_available] package redhat-support-plugin-rhev-3.3.0-13.el6ev.noarch
2014-02-11 17:26:37 DEBUG otopi.context context.dumpEnvironment:456 ENV OSETUP_RPMDISTRO/versionLockFilter=list:'['rhevm', 'redhat-support-plugin-rhev']'

Version-Release number of selected component (if applicable):
rhevm-setup-3.3.0-0.46.el6ev.noarch

How reproducible:
100%

Steps to Reproduce:
1. have a repo with newer redhat-support-plugin-rhev
2. engine-setup
3.

Actual results:
redhat-support-plugin-rhev is not updated as engine-setup does not find valid YUM group and falls back to metapackage update

Expected results:
work

Additional info:

Comment 1 Alon Bar-Lev 2014-02-11 17:23:02 UTC
This code hasn't been changed since 3.2, so either it was never tested, or the groups within the channel changed.

Nevertheless I suggest to apply this since 3.3.z.

Comment 5 Jiri Belka 2014-03-17 12:36:50 UTC
Fail, upgrade from av2.1 to av3 did not use yum group.

# yum repolist -v | sed -n '/av3/,/^$/p'
Repo-id      : av3
Repo-name    : av3
Repo-revision: 1394971743
Repo-updated : Sun Mar 16 13:06:47 2014
Repo-pkgs    : 111
Repo-size    : 1.3 G
Repo-baseurl : http://bob.eng.lab.tlv.redhat.com/builds/av3/
Repo-expire  : 21,600 second(s) (last: Mon Mar 17 13:03:10 2014)

# yum grouplist -v | grep -i rhev
   RHEV Manager (rhevm33)

# grep 'group.*rhevm' /var/log/ovirt-engine/setup/ovirt-engine-setup-20140317130251.log 
2014-03-17 13:03:02 DEBUG otopi.context context.dumpEnvironment:478 ENV OVESETUP_RPMDISTRO/packagesUpgradeList=list:'[{'packages': ['rhevm'], 'group': 'rhevm34'}]'
2014-03-17 13:03:38 DEBUG otopi.context context.dumpEnvironment:478 ENV OVESETUP_RPMDISTRO/packagesUpgradeList=list:'[{'packages': ['rhevm'], 'group': 'rhevm34'}]'
2014-03-17 13:09:30 DEBUG otopi.context context.dumpEnvironment:478 ENV OVESETUP_RPMDISTRO/packagesUpgradeList=list:'[{'packages': ['rhevm'], 'group': 'rhevm34'}]'

# grep 'YUM.*GROUP' /usr/share/ovirt-engine/setup/ovirt_engine_setup/constants.py
    UPGRADE_YUM_GROUP = 'ovirt-engine-3.4'

Comment 6 Jiri Belka 2014-03-17 12:37:29 UTC
Created attachment 875487 [details]
ovirt-engine-setup-20140317130251.log

Comment 7 Yedidyah Bar David 2014-03-17 12:46:41 UTC
(In reply to Jiri Belka from comment #5)
> Fail, upgrade from av2.1 to av3 did not use yum group.
> 
> # yum repolist -v | sed -n '/av3/,/^$/p'
> Repo-id      : av3
> Repo-name    : av3
> Repo-revision: 1394971743
> Repo-updated : Sun Mar 16 13:06:47 2014
> Repo-pkgs    : 111
> Repo-size    : 1.3 G
> Repo-baseurl : http://bob.eng.lab.tlv.redhat.com/builds/av3/
> Repo-expire  : 21,600 second(s) (last: Mon Mar 17 13:03:10 2014)
> 
> # yum grouplist -v | grep -i rhev
>    RHEV Manager (rhevm33)

This is a bug in the repo. Should be 'rhevm34'. Eyal?

> 
> # grep 'group.*rhevm'
> /var/log/ovirt-engine/setup/ovirt-engine-setup-20140317130251.log 
> 2014-03-17 13:03:02 DEBUG otopi.context context.dumpEnvironment:478 ENV
> OVESETUP_RPMDISTRO/packagesUpgradeList=list:'[{'packages': ['rhevm'],
> 'group': 'rhevm34'}]'
> 2014-03-17 13:03:38 DEBUG otopi.context context.dumpEnvironment:478 ENV
> OVESETUP_RPMDISTRO/packagesUpgradeList=list:'[{'packages': ['rhevm'],
> 'group': 'rhevm34'}]'
> 2014-03-17 13:09:30 DEBUG otopi.context context.dumpEnvironment:478 ENV
> OVESETUP_RPMDISTRO/packagesUpgradeList=list:'[{'packages': ['rhevm'],
> 'group': 'rhevm34'}]'

This is ok

> 
> # grep 'YUM.*GROUP'
> /usr/share/ovirt-engine/setup/ovirt_engine_setup/constants.py
>     UPGRADE_YUM_GROUP = 'ovirt-engine-3.4'

It's rewritten by rhevm-setup-plugins, look there

Comment 8 Alon Bar-Lev 2014-03-17 12:47:13 UTC
otopi and engine are two separate components.

When you find an issue with ovirt-engine, please open a bug on ovirt-engine and not reopen bugs.

Worse case we mark a bug as duplicate.

This bug was to detect groups based on id and not name, which was indeed otopi miniyum issue.

Comment 9 Jiri Belka 2014-03-17 13:57:46 UTC
ok, av3.

I modified repodata on our builds mirror and engine-setup reported in the log using rhevm34 yum group.

Comment 12 Itamar Heim 2014-06-12 14:07:30 UTC
Closing as part of 3.4.0


Note You need to log in before you can comment on or make changes to this bug.