Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1063896 - [RHEVM] [webadmin] [network labels] pointless right click menu for networks assigned by labeling in Setup Host Networks
Summary: [RHEVM] [webadmin] [network labels] pointless right click menu for networks a...
Keywords:
Status: CLOSED DUPLICATE of bug 1009774
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal
Version: 3.4.0
Hardware: x86_64
OS: Linux
low
low
Target Milestone: ---
: 3.4.0
Assignee: Lior Vernia
QA Contact: Martin Pavlik
URL:
Whiteboard: network
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-11 15:32 UTC by Martin Pavlik
Modified: 2016-02-10 19:47 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-24 12:33:32 UTC
oVirt Team: Network


Attachments (Terms of Use)
screenshot 1 (deleted)
2014-02-11 15:32 UTC, Martin Pavlik
no flags Details

Description Martin Pavlik 2014-02-11 15:32:18 UTC
Created attachment 861818 [details]
screenshot 1

Description of problem:
If a network is assigned to host interface based on label, right click menu contains contains only 
Menu for $label_name 
item which cannot do anything, it makes no sense to display such menu
(see screenshot)

Version-Release number of selected component (if applicable):
oVirt Engine Version: 3.4.0-0.7.beta2.el6 

How reproducible:
100%

Steps to Reproduce:
1. Have labeled (e.g. lb_storage) network (e.g. net_storage) attached to cluster 
2. label host interface with same label (lb_storage) via Setup Host Networks
3. right click on label lb_storage under Assigned Logical Networks
4. right click on network net_storage under Assigned Logical Networks

Actual results:
right click menu contains contains only item
Menu for $label_name 
which cannot do any action

Expected results:
either add some meaningful action to right click menu
or
do not display righ click menu for label and labeled network assigned

Additional info:

Comment 1 Nir Yechiel 2014-02-24 12:33:32 UTC
This is a valid bug and actually a duplicate of bug #1009774 (see comment #3 there).

*** This bug has been marked as a duplicate of bug 1009774 ***


Note You need to log in before you can comment on or make changes to this bug.