Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1063886 - 'vdsm-tool configure --force' does not configure sanlock sometimes
Summary: 'vdsm-tool configure --force' does not configure sanlock sometimes
Keywords:
Status: CLOSED DUPLICATE of bug 1057225
Alias: None
Product: oVirt
Classification: Retired
Component: vdsm
Version: 3.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 3.4.0
Assignee: Yaniv Bronhaim
QA Contact: Pavel Stehlik
URL:
Whiteboard: infra
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-11 15:24 UTC by Yedidyah Bar David
Modified: 2014-09-28 06:36 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-12 08:53:41 UTC
oVirt Team: ---


Attachments (Terms of Use)

Description Yedidyah Bar David 2014-02-11 15:24:20 UTC
Description of problem:

Under some circumstances, 'vdsm-tool configure --force' does not add sanlock to kvm/qemu groups and 'service vdsmd start' then fails.

Version-Release number of selected component (if applicable):

4.14.1-3.el6.x86_64

How reproducible:

Always?

Steps to Reproduce:
0. not sure what - probably 'vdsm-tool configure --force', starting some services
1. initctl stop libvirtd
2. service sanlock stop
3. service wdmd stop
4. remove sanlock from qemu and kvm groups in /etc/group
5. vdsm-tool configure --force
6. service vdsmd start

Actual results:

vdsmd start fails

Expected results:

should succeed

Additional info:

If after 'vdsmd start' I run again 'vdsm-tool configure --force', it correctly adds sanlock to these groups and then 'service vdsmd start' succeeds.

The actual flow was a failed attempt to install all-in-one on a clean centos machine, due to bug #1063869 , and a later attempt with a fix to that bug failed for the current bug (or so it seems based on the logs). I later reproduced using the steps above, not sure if they are applicable to a clean system.

Comment 1 Yaniv Bronhaim 2014-02-12 08:53:41 UTC

*** This bug has been marked as a duplicate of bug 1057225 ***


Note You need to log in before you can comment on or make changes to this bug.