Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1063883 - Cannot run VM for windows VM if sysprep is enabled
Summary: Cannot run VM for windows VM if sysprep is enabled
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-core
Version: 3.4
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 3.4.0
Assignee: Shahar Havivi
QA Contact: Artyom
URL:
Whiteboard: virt
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-11 15:21 UTC by Francesco Romani
Modified: 2014-12-15 12:46 UTC (History)
6 users (show)

Fixed In Version: ovirt-3.4.0-beta3
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-31 12:28:18 UTC
oVirt Team: ---


Attachments (Terms of Use)
engine log (deleted)
2014-02-11 15:21 UTC, Francesco Romani
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 24362 None None None Never
oVirt gerrit 24508 None None None Never

Description Francesco Romani 2014-02-11 15:21:09 UTC
Created attachment 861810 [details]
engine log

Description of problem:
In oVirt engine beta 2, trying to run once a windows VM with sysprep enabled (default settings) results in error, with message:
"Cannot run VM. VM is running."
In engine logs, a NullErrorException is spotted (logs attached)

However, run once can be still used if we disable the sysprep:
Run Once panel -> Boot options -> de-tick the "attach floppy" checkboc (effectively disabling sysprep AFAIK)


Version-Release number of selected component (if applicable):
engine:
  compiled locally from git tag ovirt-engine-3.4.0_beta2
jdk:
  java version "1.7.0_51"
  OpenJDK Runtime Environment (fedora-2.4.5.0.fc19-x86_64 u51-b31)
  OpenJDK 64-Bit Server VM (build 24.51-b03, mixed mode)
jboss: jboss-as-7.1.1-21.fc19.noarch


How reproducible:
100% of times on my tests

Steps to Reproduce:
1. install ovirt-engine 3.4.0 beta2 (I did from sources but shouldn't be relevant)
2. create a windows VM
3. run the windows VM with sysprep enabled (as it is by default)

Actual results:
Error message

Expected results:
Windows VM boots up

Additional info:
Linux VMs seems not affected.

In the attached logs, please note the vm is 'wintest1'; first try is succesfull (sysprep disabled); second try is UNsuccesfull and shows the behaviour dscribed here.

Comment 2 Sandro Bonazzola 2014-02-19 12:27:54 UTC
This bug is referenced in ovirt-engine-3.4.0-beta3 logs. Moving to ON_QA

Comment 3 Artyom 2014-02-24 16:38:37 UTC
Verified on ovirt-engine-3.4.0-0.11.beta3.el6.noarch
Checked via runOnce with attach floppy and simple run

Comment 4 Sandro Bonazzola 2014-03-31 12:28:18 UTC
this is an automated message: moving to Closed CURRENT RELEASE since oVirt 3.4.0 has been released


Note You need to log in before you can comment on or make changes to this bug.