Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1063873 - Multiple daemons are not "registered" in /etc/rc[0-6].d directory hierarchy (chkconfig)
Summary: Multiple daemons are not "registered" in /etc/rc[0-6].d directory hierarchy (...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-installer
Version: 3.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 3.3.4
Assignee: Alon Bar-Lev
QA Contact: bugs@ovirt.org
URL:
Whiteboard: integration
Depends On:
Blocks: 1080867
TreeView+ depends on / blocked
 
Reported: 2014-02-11 15:11 UTC by Jiri Belka
Modified: 2014-03-31 12:28 UTC (History)
5 users (show)

Fixed In Version: ovirt-3.3.4-ga
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1080867 (view as bug list)
Environment:
Last Closed: 2014-03-31 12:28:50 UTC
oVirt Team: ---


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 24338 None None None Never
oVirt gerrit 24340 None None None Never
oVirt gerrit 24368 None None None Never
oVirt gerrit 24370 None None None Never

Description Jiri Belka 2014-02-11 15:11:43 UTC
Description of problem:

I would expect daemons are present in `chkconfig --list' output. IIUC usually daemons are "registered" there with `chkconfig --add $daemon' (like postfix for example) during rpm installation. Startup/stopping is based on admin's need (`chkconfig $daemon on').

This said, I expect most admins know 'on/off' knobs of 'chkconfig', but they could be surprised not seeing all ovirt daemons there, as '--add/--del' is usually done by rpm mgmnt, and because of that they could even not know '--add/--del' :)

[root@jb-rh34 ~]# chkconfig --list | grep ovirt
ovirt-engine    0:off   1:off   2:on    3:on    4:on    5:on    6:off
ovirt-guest-agent       0:off   1:off   2:off   3:on    4:off   5:on    6:off
ovirt-websocket-proxy   0:off   1:off   2:on    3:on    4:on    5:on    6:off
[root@jb-rh34 ~]# ls /etc/init.d/ovirt-*
/etc/init.d/ovirt-engine       /etc/init.d/ovirt-engine-notifier  /etc/init.d/ovirt-websocket-proxy
/etc/init.d/ovirt-engine-dwhd  /etc/init.d/ovirt-guest-agent

Version-Release number of selected component (if applicable):
100%

How reproducible:
ovirt-engine-setup-3.4.0-0.7.beta2.el6.noarch
ovirt-engine-setup-plugin-ovirt-engine-common-3.4.0-0.7.beta2.el6.noarch
ovirt-engine-setup-base-3.4.0-0.7.beta2.el6.noarch
ovirt-engine-setup-plugin-websocket-proxy-3.4.0-0.7.beta2.el6.noarch
ovirt-engine-setup-plugin-ovirt-engine-3.4.0-0.7.beta2.el6.noarch

Steps to Reproduce:
1. install ovirt-engine
2. configured notifier
3. chkconfig --list | grep ovirt-engine-notifier

Actual results:
ovirt-engine-notifier is not known to chkconfig

Expected results:
just add all ovirt daemons but do not put them 'on' - this should be done by engine-setup or on admin's explicit request (chkconfig $daemon on)

Additional info:
also applies to dwh

Comment 1 Jiri Belka 2014-02-11 15:13:44 UTC
`chkconfig $daemon on' is too smart, it is both registering and enabling. but still, `chkconfig --list' does not show mentioned daemons...

Comment 2 Alon Bar-Lev 2014-02-11 15:16:31 UTC
Thanks!

Comment 3 Sandro Bonazzola 2014-03-31 12:28:50 UTC
This is an automated message. Moving to Closed CURRENTRELEASE since oVirt 3.3.4 has been released.


Note You need to log in before you can comment on or make changes to this bug.