Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1063869 - allinone fails on upgrade - no admin password
Summary: allinone fails on upgrade - no admin password
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-installer
Version: 3.4
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: ---
: 3.4.0
Assignee: Yedidyah Bar David
QA Contact: bugs@ovirt.org
URL:
Whiteboard: integration
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-11 15:07 UTC by Yedidyah Bar David
Modified: 2014-03-31 12:33 UTC (History)
7 users (show)

Fixed In Version: ovirt-3.4.0-beta3
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-31 12:33:15 UTC
oVirt Team: ---


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 24334 None None None Never
oVirt gerrit 24579 None None None Never

Description Yedidyah Bar David 2014-02-11 15:07:34 UTC
Description of problem:

allinone needs the admin password but does not have it during upgrades.

Version-Release number of selected component (if applicable):

3.4, probably even 3.3 (didn't try)

How reproducible:

Always

Steps to Reproduce:
1. engine-setup without allinone installed
2. install allinone plugin
3. engine-setup and choose to configure vdsm

Actual results:

setup fails

Expected results:

setup succeeds

Additional info:

We should probably either keep the password during setup (not sure where, in a 0600 file) or ask for it. Currently pushed http://gerrit.ovirt.org/24334 which asks for it.

Verified that this works, failed later for what seems like an unrelated reason, will check and might open another bug.

Comment 1 Alon Bar-Lev 2014-02-11 15:31:17 UTC
I would have disabled the all-in-one plugin if not new database, as there is no sense in doing post install of all-in-one, a simple add-host within the ui is much easier and much better supported.

Comment 2 Yedidyah Bar David 2014-02-11 15:38:17 UTC
(In reply to Alon Bar-Lev from comment #1)
> I would have disabled the all-in-one plugin if not new database, as there is
> no sense in doing post install of all-in-one, a simple add-host within the
> ui is much easier and much better supported.

I was under the impression that installing an engine on a host and later adding it as a host to the engine breaks stuff. Otherwise, why do we need allinone at all?

Comment 3 Alon Bar-Lev 2014-02-11 15:49:15 UTC
(In reply to Yedidyah Bar David from comment #2)
> (In reply to Alon Bar-Lev from comment #1)
> > I would have disabled the all-in-one plugin if not new database, as there is
> > no sense in doing post install of all-in-one, a simple add-host within the
> > ui is much easier and much better supported.
> 
> I was under the impression that installing an engine on a host and later
> adding it as a host to the engine breaks stuff. Otherwise, why do we need
> allinone at all?

1. aio was designed by PM to have working environment right out of installation.

2. aio was introduced as in the past regular host-deploy required rebooting the host.

While (2) is not valid any more, (1) is not something I can address, but sure the meaning was not to do that at upgrade.

Comment 4 Yedidyah Bar David 2014-02-17 15:08:22 UTC
Changed 24334 to prevent all-in-one during upgrade.

Comment 5 Sandro Bonazzola 2014-02-19 12:27:58 UTC
This bug is referenced in ovirt-engine-3.4.0-beta3 logs. Moving to ON_QA

Comment 6 Sandro Bonazzola 2014-03-31 12:33:15 UTC
this is an automated message: moving to Closed CURRENT RELEASE since oVirt 3.4.0 has been released


Note You need to log in before you can comment on or make changes to this bug.