Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1063802 - [RHEVM] [webadmin] [network labels] host interfaces sub-tab does not contain 'label' information
Summary: [RHEVM] [webadmin] [network labels] host interfaces sub-tab does not contain ...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal
Version: 3.4.0
Hardware: x86_64
OS: Linux
medium
low
Target Milestone: ---
: 3.5.0
Assignee: Alona Kaplan
QA Contact: Michael Burman
URL:
Whiteboard: network
Depends On:
Blocks: rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2014-02-11 13:12 UTC by Martin Pavlik
Modified: 2016-02-10 19:56 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-17 17:10:40 UTC
oVirt Team: Network
Target Upstream Version:


Attachments (Terms of Use)
screenshot 1 (deleted)
2014-02-11 13:12 UTC, Martin Pavlik
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 27898 None None None Never

Description Martin Pavlik 2014-02-11 13:12:39 UTC
Created attachment 861782 [details]
screenshot 1

Description of problem:

Due to feature description ( http://www.ovirt.org/Features/NetworkLabels )

User Experience:
For managing labels on host level:
In host interfaces sub-tab a column labels will present the labels.

There is no such column.

Version-Release number of selected component (if applicable):
oVirt Engine Version: 3.4.0-0.7.beta2.el6 

How reproducible:
100%


Actual results:
no 'labels' column present in Host -> your host -> Network Interfaces (see screenshot)

Expected results:
'labels' present column in Host -> your host -> Network Interfaces

Comment 1 Nir Yechiel 2014-02-12 13:31:13 UTC
@Martin, instead of adding an additional column for the labels, would it make sense to add a new icon in the "Network Name" column, to mark each network which was assigned to the host via a label?

Comment 2 Martin Pavlik 2014-02-12 14:04:01 UTC
@Nir, 

yes, icon would be OK, especially if it showed used labels after hoovering over it. I filled bug based on feature description from ovirt wiki, that is why I requested column.

Comment 3 Moti Asayag 2014-02-12 14:21:04 UTC
(In reply to Martin Pavlik from comment #2)
> @Nir, 
> 
> yes, icon would be OK, especially if it showed used labels after hoovering
> over it. I filled bug based on feature description from ovirt wiki, that is
> why I requested column.

In this specific context I'd expect to see if the specific network which is configured on the nic is managed by label or not.
I don't see a need for any further information, since we're already in the context of a specific network which its label already visible in the main tab.

Comment 4 Alona Kaplan 2014-05-25 06:56:43 UTC
'name' or 'bond' column will contain tag image if the interface have label. The tooltip of the tag image will contain the list of the labels on this interface.

The subtab will not represent if a network is attached to nic via label. To see this there user will have to open the setup networks dialog.

Comment 6 Michael Burman 2014-07-16 13:57:51 UTC
Verified on-  oVirt Engine Version: 3.5.0-0.0.master.20140715172116.git4687dc1.el6

Comment 8 Eyal Edri 2015-02-17 17:10:40 UTC
rhev 3.5.0 was released. closing.


Note You need to log in before you can comment on or make changes to this bug.