Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1063712 - [engine install] engine setup asks for default datacenter type according to storage type and not Shared/Local
Summary: [engine install] engine setup asks for default datacenter type according to s...
Keywords:
Status: CLOSED DUPLICATE of bug 1102021
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-installer
Version: 3.4
Hardware: All
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.5.0
Assignee: Simone Tiraboschi
QA Contact: bugs@ovirt.org
URL:
Whiteboard: integration
: 1073849 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-11 10:08 UTC by Gadi Ickowicz
Modified: 2014-09-04 08:47 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-04 08:47:29 UTC
oVirt Team: ---


Attachments (Terms of Use)
setup log (deleted)
2014-02-11 10:08 UTC, Gadi Ickowicz
no flags Details

Description Gadi Ickowicz 2014-02-11 10:08:32 UTC
Created attachment 861737 [details]
setup log

Description of problem:
When running engine-setup, one of the steps allows the user to choose the default storage type for the datacenter that is created. The choices are listed as:
Default storage type: (NFS, FC, ISCSI, POSIXFS) [NFS]:

However the new datacenter types are either Local or Shared. engine-setup should reflect this change.

Version-Release number of selected component (if applicable):
ovirt-engine-setup-3.4.0-0.7.beta2.el6.noarch
ovirt-engine-3.4.0-0.7.beta2.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1. yum install ovirt-engine
2. engine-setup

Comment 1 Itamar Heim 2014-02-11 23:21:13 UTC
I think it means we can drop this question. main use case this would help is all-in-one, and that flow has its own plugin to choose local storage

Comment 2 Sven Kieske 2014-02-13 12:29:05 UTC
(In reply to Itamar Heim from comment #1)
> I think it means we can drop this question. main use case this would help is
> all-in-one, and that flow has its own plugin to choose local storage


And what about your local storage users?
Wouldn't this mean I get forced to configure some shared storage, even if I don't
use it?
Please elaborate a bit, thank you.

Comment 3 Itamar Heim 2014-02-13 12:34:54 UTC
I'd expect deployment with local storage to probably use the all-in-one mode?
and this is only about the default DC mode. you can always create another DC for local storage if you want.
(the only reason this question was added was since its not possible to edit the storage type of the default DC post install, but with shared/local, I was assuming most deployments could live with default DC being shared?)

Comment 4 Sven Kieske 2014-02-13 12:43:42 UTC
Well, I do _not_ use all in one mode, because I do not want vms on the engine
host at all (and no vdsm there, I try to keep it as minimal as possible).

So if you make this change this could maybe confuse some users and lead to
useless software being installed etc.

On the other hand, I don't care about the storage type of the default DC
as I don't use it (I create my own ones).

PS: Is it safe to remove the default DC? In previous releases the docs stated
this was a not recommmended action.

PPS: Is there a maxium number of managed DCs from one engine host?
I just know that you can have 200 Hosts in one Cluster, but didn't find any maximum Datacenter per Engine number in the docs (ovirt or rhev).

If you still should not remove the default DC it would be cool to know the reason
and it would also be cool if an unconfigured default DC would not produce any
log noise (I didn't check if this ist the case atm).

Thanks for the fast reply!

Comment 5 Alon Bar-Lev 2014-02-17 15:33:40 UTC
>  Ofer Schreiber 2014-02-17 10:29:44 EST
> Target Release: 3.4.0 → 3.4.1
	
I do not think this is z-stream, we should decide if we provide this or not, and if we do, set minor version milestone.

Comment 6 Einav Cohen 2014-06-02 17:38:19 UTC
removing the UserExperience keyword - user experience design advice is not needed here.

Comment 7 Sandro Bonazzola 2014-06-11 07:06:51 UTC
This is an automated message:
This bug has been re-targeted from 3.4.2 to 3.5.0 since neither priority nor severity were high or urgent. Please re-target to 3.4.3 if relevant.

Comment 9 Simone Tiraboschi 2014-09-02 12:58:14 UTC
*** Bug 1073849 has been marked as a duplicate of this bug. ***

Comment 10 Simone Tiraboschi 2014-09-04 08:47:29 UTC

*** This bug has been marked as a duplicate of bug 1102021 ***


Note You need to log in before you can comment on or make changes to this bug.