Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1063683 - [RFE] show bridge/bond/VLAN UP/DOWN status on Host -> Network Interfaces subtab
Summary: [RFE] show bridge/bond/VLAN UP/DOWN status on Host -> Network Interfaces subtab
Keywords:
Status: CLOSED DUPLICATE of bug 1079719
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: RFEs
Version: 3.4.0
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
: 3.5.0
Assignee: Andrew Cathrow
QA Contact: Shai Revivo
URL:
Whiteboard: network
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-11 09:20 UTC by Martin Pavlik
Modified: 2016-02-10 19:52 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-17 14:33:43 UTC
oVirt Team: Network
nyechiel: Triaged+


Attachments (Terms of Use)
screenshot 1 (deleted)
2014-02-11 09:20 UTC, Martin Pavlik
no flags Details
Up-to-date interface view (deleted)
2014-07-17 09:51 UTC, Lior Vernia
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 675560 None None None Never

Internal Links: 675560

Description Martin Pavlik 2014-02-11 09:20:07 UTC
Created attachment 861722 [details]
screenshot 1

Description of problem:

In 3.4 vdsm provides information about UP/DOWN states of bridge/bond/VLAN , this information is not shown to the user.

This information could be indicated by changing icon color (red/green). 

See screenshot.

Additional info:

Information provided by vdsm

	network = {';vdsmdummy;': {'name': ';vdsmdummy;',
	                           'rxDropped': '0',
	                           'rxErrors': '0',
	                           'rxRate': '0.0',
	                           'speed': '1000',
	                           'state': 'down',
	                           'txDropped': '0',
	                           'txErrors': '0',
	                           'txRate': '0.0'},
	           'NET_VMs': {'name': 'NET_VMs',
	                       'rxDropped': '0',
	                       'rxErrors': '0',
	                       'rxRate': '0.0',
	                       'speed': '1000',
	                       'state': 'up',
	                       'txDropped': '0',
	                       'txErrors': '0',
	                       'txRate': '0.0'},
	           'VLAN_1': {'name': 'VLAN_1',
	                      'rxDropped': '0',
	                      'rxErrors': '0',
	                      'rxRate': '0.0',
	                      'speed': '1000',
	                      'state': 'up',
	                      'txDropped': '0',
	                      'txErrors': '0',
	                      'txRate': '0.0'},
	           'VLAN_2': {'name': 'VLAN_2',
	                      'rxDropped': '0',
	                      'rxErrors': '0',
	                      'rxRate': '0.0',
	                      'speed': '1000',
	                      'state': 'up',
	                      'txDropped': '0',
	                      'txErrors': '0',
	                      'txRate': '0.0'},
	           'VLAN_3': {'name': 'VLAN_3',
	                      'rxDropped': '0',
	                      'rxErrors': '0',
	                      'rxRate': '0.0',
	                      'speed': '1000',
	                      'state': 'up',
	                      'txDropped': '0',
	                      'txErrors': '0',
	                      'txRate': '0.0'},
	           'bond0': {'name': 'bond0',
	                     'rxDropped': '0',
	                     'rxErrors': '0',
	                     'rxRate': '0.0',
	                     'speed': '1000',
	                     'state': 'down',
	                     'txDropped': '0',
	                     'txErrors': '0',
	                     'txRate': '0.0'},
	           'bond1': {'name': 'bond1',
	                     'rxDropped': '0',
	                     'rxErrors': '0',
	                     'rxRate': '0.0',
	                     'speed': '1000',
	                     'state': 'up',
	                     'txDropped': '0',
	                     'txErrors': '0',
	                     'txRate': '0.0'},
	           'bond1.1': {'name': 'bond1.1',
	                       'rxDropped': '0',
	                       'rxErrors': '0',
	                       'rxRate': '0.0',
	                       'speed': '1000',
	                       'state': 'up',
	                       'txDropped': '0',
	                       'txErrors': '0',
	                       'txRate': '0.0'},
	           'bond1.123': {'name': 'bond1.123',
	                         'rxDropped': '0',
	                         'rxErrors': '0',
	                         'rxRate': '0.0',
	                         'speed': '1000',
	                         'state': 'up',
	                         'txDropped': '0',
	                         'txErrors': '0',
	                         'txRate': '0.0'},
	           'bond1.2': {'name': 'bond1.2',
	                       'rxDropped': '0',
	                       'rxErrors': '0',
	                       'rxRate': '0.0',
	                       'speed': '1000',
	                       'state': 'up',
	                       'txDropped': '0',
	                       'txErrors': '0',
	                       'txRate': '0.0'},
	           'bond1.3': {'name': 'bond1.3',
	                       'rxDropped': '0',
	                       'rxErrors': '0',
	                       'rxRate': '0.0',
	                       'speed': '1000',
	                       'state': 'up',
	                       'txDropped': '0',
	                       'txErrors': '0',
	                       'txRate': '0.0'},
	           'ovirtmgmt': {'name': 'ovirtmgmt',
	                         'rxDropped': '0',
	                         'rxErrors': '0',
	                         'rxRate': '0.2',
	                         'speed': '1000',
	                         'state': 'up',
	                         'txDropped': '0',
	                         'txErrors': '0',
	                         'txRate': '0.0'},
	           'p1p1': {'name': 'p1p1',
	                    'rxDropped': '0',
	                    'rxErrors': '0',
	                    'rxRate': '0.0',
	                    'speed': '1000',
	                    'state': 'up',
	                    'txDropped': '0',
	                    'txErrors': '0',
	                    'txRate': '0.0'},
	           'p1p2': {'name': 'p1p2',
	                    'rxDropped': '0',
	                    'rxErrors': '0',
	                    'rxRate': '0.0',
	                    'speed': '1000',
	                    'state': 'up',
	                    'txDropped': '0',
	                    'txErrors': '0',
	                    'txRate': '0.0'}}

Comment 1 Lior Vernia 2014-07-17 09:50:08 UTC
Bond status is now included in the subtab, but I am not convinced bridge and VLAN status should be added - the fact that networks are represented by bridges on hosts is an implementation detail that we usually try to abstract away from the oVirt user (VLAN devices are similar, and in fact we had made an error when we hadn't abstracted that implementation detail in our API, for example).

Nir, what do you think?

Adding an up-to-date screenshot.

Comment 2 Lior Vernia 2014-07-17 09:51:02 UTC
Created attachment 918655 [details]
Up-to-date interface view

Comment 3 Nir Yechiel 2014-07-17 14:07:00 UTC
(In reply to Lior Vernia from comment #1)
> Bond status is now included in the subtab, but I am not convinced bridge and
> VLAN status should be added - the fact that networks are represented by
> bridges on hosts is an implementation detail that we usually try to abstract
> away from the oVirt user (VLAN devices are similar, and in fact we had made
> an error when we hadn't abstracted that implementation detail in our API,
> for example).
> 
> Nir, what do you think?
> 
> Adding an up-to-date screenshot.

Martin, what exact information would you expect here? 
IMHO, the critical information we need to include is the physical devices (i.e., interface/bond) status as we do today, and the *accurate* B/W utilization as requested on BZ 1063343.

Comment 4 Martin Pavlik 2014-07-17 14:33:43 UTC
My original thought was ability to see quickly if someone shuts VLAN/bridge down on host by mistake. But if we stick with the fact that in present state network should be manipulated only over GUI (or API) it should not be needed.

All in all I think we can go with:

physical devices (i.e., interface/bond) status as we do today, and the *accurate* B/W utilization as requested on BZ 1063343.

closing as current release (bond state was added already)

Comment 5 Lior Vernia 2014-07-20 08:48:37 UTC
Not quite a duplicate, but last piece (bond status) was solved as part of that bug.

*** This bug has been marked as a duplicate of bug 1079719 ***


Note You need to log in before you can comment on or make changes to this bug.