Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1063548 - Email notification for cleared flag does not identify the flag requestee
Summary: Email notification for cleared flag does not identify the flag requestee
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Bugzilla
Classification: Community
Component: Email Notifications
Version: 4.4
Hardware: Unspecified
OS: Unspecified
medium
low vote
Target Milestone: 4.4
Assignee: Matt Tyson 🤬
QA Contact: Simon Green
URL:
Whiteboard:
: 1063175 (view as bug list)
Depends On:
Blocks: 1063175
TreeView+ depends on / blocked
 
Reported: 2014-02-11 01:18 UTC by Jason McDonald
Modified: 2018-12-09 06:29 UTC (History)
5 users (show)

Fixed In Version: 4.4.2015
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-13 00:51:35 UTC


Attachments (Terms of Use)

Description Jason McDonald 2014-02-11 01:18:11 UTC
Description of problem:
Some Bugzilla flags have an associated requestee field (e.g. the needinfo flag has this field).  When a request for such a flag is granted/denied/canceled, the notification email does not display the identity of the requestee.  This omission makes it look like bugzilla is sending duplicate notifications when multiple instances of the same flag are granted/denied/canceled at the same time.

The relevant section of the notification email looks like this:

    J. Random Hacker <jrhacker@example.com> has canceled SW User
    <swuser@example.com>'s request for needinfo:
    Bug 1234567: Too many notification emails
    https://bugzilla.redhat.com/show_bug.cgi?id=1234567

For flags with a requestee set, it would perhaps be better if the second line looked something like:

    <swuser@example.com>'s request for needinfo from B.Z. Guru <bz.guru@example.com>:

Version-Release number of selected component (if applicable):
4.4.1013

How reproducible:
Always

Steps to Reproduce:
0. Make sure your BZ email preferences are set to send you notifications for flag changes.
1. Set two needinfo flags on the same bug and save.
2. Clear both needinfo flags.
3. Look in your inbox.

Actual results:
Two identical notification messages are received.

Expected results:
Two similar notifications are received, identifying the separsate needinfo flags that were canceled.

Additional info:
nil

Comment 1 Matt Tyson 🤬 2014-02-17 04:49:38 UTC
I'm not sure I can replicate this.

When I set two needinfo flags on the same bug, save, then clear the flags, both flag requester get two emails

One email shows that the requestors needinfo flag has been cleared.
The other is the more general update email showing that both the needinfo flags have been removed.

Comment 2 Simon Green 2014-03-11 12:22:32 UTC
*** Bug 1063175 has been marked as a duplicate of this bug. ***

Comment 3 Matt Tyson 🤬 2014-03-13 00:51:35 UTC
This change is now live. If there are any issues, do not reopen this bug.
Instead, you should create a new bug and reference this bug.


Note You need to log in before you can comment on or make changes to this bug.