Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1063436 - New files are created with 2 commits on git instead of just one
Summary: New files are created with 2 commits on git instead of just one
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss BRMS Platform 6
Classification: Retired
Component: Business Central
Version: 6.0.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ER2
: 6.0.1
Assignee: Alexandre Porcelli
QA Contact: Lukáš Petrovický
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-10 18:10 UTC by Alexandre Porcelli
Modified: 2014-08-06 19:57 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-06 19:57:20 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1066985 None None None Never

Internal Links: 1066985

Description Alexandre Porcelli 2014-02-10 18:10:08 UTC
Description of problem:

New files are creating 2 commits instead of one.. this happens because all create services are using IOService.createFile followed by IOService.write.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Jiri Locker 2014-02-24 11:34:32 UTC
Didn't make it into ER1.

Comment 3 Lukáš Petrovický 2014-03-05 18:08:08 UTC
Each asset is now created with just one commit, VERIFIED with ER2.

commit 1820fca9358712f38766057af2d690e44ffcca05
Author: testadmin <>
Date:   Wed Mar 5 06:33:40 2014 -0500

    Created asset WorkDefinitions.wid

commit 3192010e958489274cf6de5782841cb98cc8457f
Author: testadmin <>
Date:   Wed Mar 5 06:33:37 2014 -0500

    Created asset process.bpmn2


Note You need to log in before you can comment on or make changes to this bug.