Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1063409 - Provisioning on RHEL 7 VHost creates kvm guests having no gfx just serial console
Summary: Provisioning on RHEL 7 VHost creates kvm guests having no gfx just serial con...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Provisioning
Version: 560
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Stephen Herr
QA Contact: Dimitar Yordanov
URL:
Whiteboard:
Depends On:
Blocks: sat560-triage
TreeView+ depends on / blocked
 
Reported: 2014-02-10 16:15 UTC by Lukas Pramuk
Modified: 2014-06-10 13:16 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-10 13:16:12 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:0676 normal SHIPPED_LIVE Red Hat Network Tools bug fix update 2014-06-10 17:07:18 UTC

Description Lukas Pramuk 2014-02-10 16:15:50 UTC
Description of problem:
KVM guest provisioning on RHEL7 VHOst using Satellite WebUI creates guest having no graphics just only serial console. 

Version-Release number of selected component (if applicable):
koan-2.0.7-41.el7sat.noarch
spacewalk-koan-2.0.1-3.el7sat.noarch

How reproducible:
100%

Steps to Reproduce:
1. Use Satellite webUI to provision RHEL5/6 KVM guest on RHEL7 KVM host. This
   command is issued:
# rhn_check -vv
[...]
D: handle_action{'action': "<?xml version='1.0'?>\n<methodCall>\n<methodName>kickstart_guest.initiate</methodName>\n<params>\n<param>\n<value><string>[SAT]</string></value>\n</param>\n<param>\n<value><string>[VHOST]:1:kvmsystem</string></value>\n</param>\n<param>\n<value><string>qemu</string></value>\n</param>\n<param>\n<value><int>482</int></value>\n</param>\n<param>\n<value><string>kvmsystem</string></value>\n</param>\n<param>\n<value><int>512</int></value>\n</param>\n<param>\n<value><int>1</int></value>\n</param>\n<param>\n<value><int>3</int></value>\n</param>\n<param>\n<value><string>virbr0</string></value>\n</param>\n<param>\n<value><string>/var/lib/libvirt/images/kvmsystem</string></value>\n</param>\n<param>\n<value><string> </string></value>\n</param>\n</params>\n</methodCall>\n", 'version': 2, 'id': 15477}
D: handle_action actionid = 15477, version = 2
D: do_call kickstart_guest.initiate('<SAT>', '<VHOST>:1:kvmsystem', 'qemu', 482, 'kvmsystem', 512, 1, 3, 'virbr0', '/var/lib/libvirt/images/kvmsystem', ' '){'cache_only': None}
- looking for Cobbler at http://<SAT>/cobbler_api
- reading URL: http://<SAT>/cblr/svc/op/ks/system/<VHOST>:1:kvmsystem
install_tree: http://<SAT>/ty/PDDQsUo1
- ['rpm', '-q', 'virt-install']
- ['virt-install', '--version']
- ['virt-install', '--os-variant', 'list']
- adding disk: /var/lib/libvirt/images/kvmsystem of size 3 (driver type=None)
- ['virt-install', '--connect', 'qemu:///system', '--name', 'kvmsystem', '--ram', '512', '--vcpus', '1', '--autostart', '--nographics', '--virt-type', 'kvm', '--machine
Starting install...
[...]

Actual results:
VM has no gfx

Expected results:
VM has gfx and display defined

Additional info:
when koan invokes virt-install it should omit '--nographics' option.
(This options is not related to the type of install method)

Comment 1 Pavel Studeník 2014-02-10 16:37:44 UTC
If I want look at progress of installation in virt-manager (when option "--nographics" is set and I can't use graphics) I need add extra kernel's parameter "console=ttyS0" for working serial console mode.

My expected behaviour is
 * if graphics is disabled, then a serial console works correct
 * if serial console is disabled, then a graphics works correct

Comment 2 Stephen Herr 2014-03-25 17:40:27 UTC
Update: this is unrelated to RHEL 7, this is how spacewalk-koan has always worked. I'm not saying we shouldn't fix it, just that it's not new behavior.

Comment 3 Stephen Herr 2014-03-26 21:15:58 UTC
LPramuk told me I need to take another look at this so I have. There is in fact a behavior difference between RHEL 5, 6 hosts and RHEL 7 hosts.

The koan package that we provide on RHEL 5, 6 hosts fails to deal correctly with the no_gfx option (when using kvm/qemu virtualization) that spacewalk-koan has always set. So the upshot was that you would always get a vnc graphical console even though spacewalk-koan was trying to tell it not to. In RHEL 7 koan is actually correctly doing what we're telling it to do, which is undesired behavior.

Since no one has ever complained about having this graphical console, I will remove the bit from spacewalk-koan that sets the no_gfx option. This will make RHEL 7 guest provisioning work the same as it does on RHEL 6 and 5, and enable to you easily watch what is happening on the guest through virt-viewer or whatever.

Comment 4 Stephen Herr 2014-03-26 21:26:29 UTC
Committed to Spacewalk master:
5becd6d5b0b267908f4202dcb8b9aea39646ae36

Comment 8 errata-xmlrpc 2014-06-10 13:16:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0676.html


Note You need to log in before you can comment on or make changes to this bug.