Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1063394 - Guided editor: values from nested enum are not reloaded after reopening the rule
Summary: Guided editor: values from nested enum are not reloaded after reopening the rule
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss BRMS Platform 6
Classification: Retired
Component: Business Central
Version: 6.0.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ER2
: 6.0.1
Assignee: manstis
QA Contact: Jiri Locker
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-10 15:47 UTC by Jiri Locker
Modified: 2014-08-06 19:57 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-06 19:57:43 UTC
Type: Bug


Attachments (Terms of Use)
Person.java (deleted)
2014-02-11 15:32 UTC, Jiri Locker
no flags Details

Description Jiri Locker 2014-02-10 15:47:55 UTC
Description of problem:
I can successfully use nested Java enums thanks to fixing bug 1047879. But when I save the rule and reopen it the enum select box is reset to "Choose..." and contains no other values.

Version-Release number of selected component (if applicable):
CR2

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:
Enum select box is reset and doesn't contains enum values after reopening the rule.

Expected results:
Guided editor should reopen the rule exactly as it was saved. All nested enum values should be loaded into the select box.

Additional info:

Comment 1 manstis 2014-02-11 13:38:12 UTC
Hello, I used the Person2.jar in the referenced BZ and created a rule with Person( sex == Sex.MALE ); saved it and re-opened it without any problem. Can you please advise if I've missed something out?

Comment 2 Jiri Locker 2014-02-11 15:32:12 UTC
Created attachment 861817 [details]
Person.java

Mike, I believe you will replicate if you commit and push this class to a project (updating the package declaration) and use it instead of model uploaded in a jar.

Comment 3 manstis 2014-02-12 12:13:11 UTC
Hi Jiri. I made a JAR with the provided class (thanks for that) and things still worked as expected/required. I'll try again pushing the source to the repository as you suggest too.. it has to be something specific to this specific use-case.

Comment 4 manstis 2014-02-12 13:20:17 UTC
Hi Jiri, I've managed to do that now and it still works OK. Are you sure you've not performed any additional other steps too? I simply cloned (with SSH), added the class, committed, pushed, saw the class in the workbench, made a rule using it (as described elsewhere), saved it, closed the editor and re-opened it. Still working ok... I'll try stopping server and restarting...

Comment 5 manstis 2014-02-19 13:36:08 UTC
I tried stopping and restarting.. everything appears to be working OK.

Did you want to set to MODIFIED and check with the next release (in case there's been a change made elsewhere for something else that has fixed the issue)?

Comment 6 Jiri Locker 2014-02-27 18:03:44 UTC
Thanks for trying. This is only reproducible if there is another Person class in the project. Bug 1069288 will probably fix this one too.


Note You need to log in before you can comment on or make changes to this bug.