Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1063333 - Existing /var/lib/mysql/mysql.sock prevents mysqld from starting after system crash
Summary: Existing /var/lib/mysql/mysql.sock prevents mysqld from starting after system...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: mariadb
Version: 19
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Honza Horak
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-10 14:16 UTC by Rolf Fokkens
Modified: 2014-06-27 13:40 UTC (History)
2 users (show)

Fixed In Version: mariadb-5.5.35-2.fc19
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-27 13:40:07 UTC


Attachments (Terms of Use)

Description Rolf Fokkens 2014-02-10 14:16:54 UTC
Description of problem:
After a system crash an existing /var/lib/mysql/mysql.sock prevents mysqld from starting.

I'm not sure why mysqld complains, probably because one may assume that there's another daemon already running. It may also indicate an unhealthy shutdown which needs looking into, in a cryptical way.

Potential solutions:
- During early boot stages the OS might remove any existing mysql.sock file. 
- The mysql.sock file might be moved to /var/run/... which is clean anyway during boot.

Version-Release number of selected component (if applicable):
mariadb-server-5.5.34-1.fc19.x86_64

How reproducible:
100%

Steps to Reproduce:
1. have a VM running mariadb (mysqld)
2. do a force quit (virtually yank out the power cord)
3. start the VM

Actual results:
Mysqld won't startup due to existing mysql.sock file

Expected results:
A happily starting mysqld; because there's no mysql.sock file during boot.

Additional info:
Moving the mysql.sock file to /var/run might be the right thing to do, and probably an easy one: just modify my.cnf.

Comment 1 Honza Horak 2014-02-11 12:58:01 UTC
Thanks for reporting. I believe this issue should be fixed in the upcomming build mariadb-5.5.35-2.fc19, currently available in the testing repository:
https://admin.fedoraproject.org/updates/FEDORA-2014-2137/mariadb-5.5.35-2.fc19

Feel free to test it and provide karma or feedback if it helps in your case, thanks.

Comment 2 Honza Horak 2014-06-27 13:40:07 UTC
Since there has been no response for some time, I believe it really has been fixed by mariadb-5.5.35-2.fc19. Feel free to re-open if it happens agian.


Note You need to log in before you can comment on or make changes to this bug.