Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1063325 - Installer crashes during installation of RHEL 7 SS4
Summary: Installer crashes during installation of RHEL 7 SS4
Keywords:
Status: CLOSED DUPLICATE
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda
Version: 7.0
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: rc
: ---
Assignee: Anaconda Maintenance Team
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-10 14:01 UTC by Hemanth M B
Modified: 2014-02-14 12:41 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-14 12:41:19 UTC


Attachments (Terms of Use)
ScreenShots (deleted)
2014-02-10 14:01 UTC, Hemanth M B
no flags Details
anaconda and syslog logs (deleted)
2014-02-14 05:34 UTC, Hemanth M B
no flags Details

Description Hemanth M B 2014-02-10 14:01:28 UTC
Created attachment 861398 [details]
ScreenShots

Description of problem: Installer crashes during installation of RHEL 7 SS4


Version-Release number of selected component (if applicable):


How reproducible:

It is my observation that during the snapshot 4 installation of RH7, the OS is unable to differentiate an unplugged port from a port that is connected. As a result it shows the on/off switch on all ports. If a particular port is unassigned in the VC server profile on an HP C7000 chassis, and if I toggle the switch from off to on the install screen of RH7 SS4 , the installer crashes/reboots and the cycle repeats. However, if I do so on a port that is connected, I don’t see any issue.

This however is different in SS2. In the SS2, the ports that are connected are clearly shown as connected and only these ports have an on/off toggle. The unassigned ports are shown as unplugged and have no on/off switch and hence there is no chance of flipping them .


Steps to Reproduce:
1. mount the DVD and start the installation.
2. at configuration page. configure network interface which is not connected. Toggle the switch from off to on
3. an error message will be popped up.

Actual results:


Expected results:


Additional info:
Observed similar behavior on HP 350p Gen8 server with 57810/57840 cards. For more information please see the sceern shots

Comment 2 Jirka Klimes 2014-02-11 09:27:25 UTC
It looks like an anaconda fault to me. But to be able to debug further, we need logs. Would you grab them so that we could analyze?

Switch to tty2 and find the logs in /tmp, mainly syslog and anaconda.log.
See e.g. https://fedoraproject.org/wiki/How_to_debug_installation_problems for more details.

Comment 3 Hemanth M B 2014-02-14 05:34:07 UTC
Created attachment 863094 [details]
anaconda and syslog logs

Please find the anaconda and syslog logs attached.

Comment 4 Jirka Klimes 2014-02-14 11:43:25 UTC
Anaconda traceback:
anaconda 19.31.51-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/gi/types.py", line 113, in function
    return info.invoke(*args, **kwargs)
  File "/usr/lib64/python2.7/site-packages/gi/overrides/Gio.py", line 171, in __call__
    None)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/nm.py", line 676, in nm_activate_device_connection
    nm_proxy.ActivateConnection('(ooo)', con_paths[0], device_path, "/")
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/network.py", line 593, in on_device_off_toggled
    nm.nm_activate_device_connection(dev_name, dev_cfg.con_uuid)
GError: GDBus.Error:org.freedesktop.NetworkManager.UnknownConnection: Connection 'em1' is not available on the device em1 at this time.

Local variables in innermost frame:
info: <gi.FunctionInfo object (call_sync) at 0x0x7fdadec225a8>
args: (<DBusProxy object at 0x7fdacdcd1320 (GDBusProxy at 0x3e82b70)>, 'ActivateConnection', GLib.Variant('(ooo)', ('/org/freedesktop/NetworkManager/Settings/1', '/org/freedesktop/NetworkManager/Devices/2', '/')), 0, -1, None)
kwargs: {}

So anaconda tries to activate 'em1' connection profile, but it is not available for the device. And the installer quits on the error. I'm not sure why the profile is not available for the device, maybe some timing issue. But the error should be handled more gracefully in anaconda.
Re-assigning to anaconda for opinion. Especially, what is the difference in SS2 and SS4?

Comment 5 Radek Vykydal 2014-02-14 12:41:19 UTC
(In reply to Jirka Klimes from comment #4)

> 
> So anaconda tries to activate 'em1' connection profile, but it is not
> available for the device. And the installer quits on the error. I'm not sure
> why the profile is not available for the device, maybe some timing issue.
> But the error should be handled more gracefully in anaconda.
> Re-assigning to anaconda for opinion. Especially, what is the difference in
> SS2 and SS4?

see bug #1062417 comment #6

*** This bug has been marked as a duplicate of bug 1062417 ***


Note You need to log in before you can comment on or make changes to this bug.