Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1063276 - Cannot login as admin@internal
Summary: Cannot login as admin@internal
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-core
Version: 3.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 3.4.0
Assignee: Martin Perina
QA Contact: Petr Beňas
URL:
Whiteboard: infra
: 1060410 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-10 11:55 UTC by Martin Perina
Modified: 2014-03-31 12:29 UTC (History)
7 users (show)

Fixed In Version: ovirt-3.4.0-beta3
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-31 12:29:02 UTC
oVirt Team: ---


Attachments (Terms of Use)
Logs (deleted)
2014-02-10 11:55 UTC, Martin Perina
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 24277 None None None Never
oVirt gerrit 24290 None None None Never

Description Martin Perina 2014-02-10 11:55:22 UTC
Created attachment 861355 [details]
Logs

Description of problem:

Cannot login as admin@internal due to NullPointerException in DbUserCacheManager.


Version-Release number of selected component (if applicable):

Compile from master

How reproducible:

Every time

Steps to Reproduce:
1. Run engine-setup

2. Add domain using engine-managed-domain

    engine-manage-domains add --domain=ad2.rhev.lab.eng.brq.redhat.com --provider=ad --user=vdcadmin --add-permissions
3. Start engine and try to login as admin@internal

Actual results:

Error: User must exist in directory

Expected results:

It should be possible to login as admin@internal 

Additional info:

Login as vdcadmin@ad2.rhev.lab.eng.brq.redhat.com works fine.

Comment 1 Yair Zaslavsky 2014-02-10 12:38:43 UTC
1. This occurs on master
2. We need to check at that the code reaches InternalAuthenticator.authenticate

at this point, the config values for the admin user and password are used.

Martin, can you provide the commit hash of master you detected this on?

Comment 2 Martin Perina 2014-02-10 14:02:44 UTC
Commit hash is 1260963e2ee6d7b2579ae3c4132789c98a8412b0

This flow doesn't work

1) Setup
2) Add domain using engine-manage-domains
3) Login as admin@internal -> Error


But this flow work fine:

1) Setup
2) Login as admin@internal -> OK
3) Add domain using engine-manage-domains
4) Login as admin@internal -> OK

I will debug this to find out more

Comment 3 Martin Perina 2014-02-11 12:44:35 UTC
*** Bug 1060410 has been marked as a duplicate of this bug. ***

Comment 4 Itamar Heim 2014-02-16 08:23:14 UTC
Setting target release to current version for consideration and review. please
do not push non-RFE bugs to an undefined target release to make sure bugs are
reviewed for relevancy, fix, closure, etc.

Comment 5 Sandro Bonazzola 2014-02-19 12:26:29 UTC
This bug is referenced in ovirt-engine-3.4.0-beta3 logs. Moving to ON_QA

Comment 6 Petr Beňas 2014-02-20 14:58:12 UTC
Verified in 3.4.0-0.11.beta3.el6.

Comment 7 Sandro Bonazzola 2014-03-31 12:29:02 UTC
this is an automated message: moving to Closed CURRENT RELEASE since oVirt 3.4.0 has been released


Note You need to log in before you can comment on or make changes to this bug.