Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1063190 - [RHEV-RHS] Volume was not accessible after server side quorum was met
Summary: [RHEV-RHS] Volume was not accessible after server side quorum was met
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: replicate
Version: mainline
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Pranith Kumar K
QA Contact:
URL:
Whiteboard:
Depends On: 1061580
Blocks: 1062256
TreeView+ depends on / blocked
 
Reported: 2014-02-10 09:08 UTC by Pranith Kumar K
Modified: 2014-06-24 11:03 UTC (History)
14 users (show)

Fixed In Version: glusterfs-3.5.1beta
Doc Type: Bug Fix
Doc Text:
Clone Of: 1061580
Environment:
virt rhev integration
Last Closed: 2014-06-24 11:03:20 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Anand Avati 2014-02-10 09:09:22 UTC
REVIEW: http://review.gluster.org/6944 (cluster/afr: Remove eager-lock stub on finodelk failure) posted (#1) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 2 Anand Avati 2014-02-10 10:11:44 UTC
REVIEW: http://review.gluster.org/6944 (cluster/afr: Remove eager-lock stub on finodelk failure) posted (#2) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 3 Anand Avati 2014-03-25 02:37:16 UTC
REVIEW: http://review.gluster.org/6944 (cluster/afr: Remove eager-lock stub on finodelk failure) posted (#3) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 4 Anand Avati 2014-04-02 17:50:44 UTC
COMMIT: http://review.gluster.org/6944 committed in master by Anand Avati (avati@redhat.com) 
------
commit e75be8977ede9b9174d20b39c427e6fb4ccde567
Author: Pranith Kumar K <pkarampu@redhat.com>
Date:   Mon Mar 24 22:54:03 2014 +0530

    cluster/afr: Remove eager-lock stub on finodelk failure
    
    Problem:
    For write fops afr's transaction eager-lock init adds transactions
    that can share eager-lock to fdctx list. But if eager-lock finodelk
    fop fails the stub remains in the list. This could later lead to
    corruption of the list and lead to infinite loop on the list
    leading to a mount hang.
    
    Fix:
    Remove the stub when finodelk fails.
    
    Change-Id: I0ed4bc6b62f26c5e891c1181a6871ee6e4f4f5fd
    BUG: 1063190
    Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
    Reviewed-on: http://review.gluster.org/6944
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Ravishankar N <ravishankar@redhat.com>
    Reviewed-by: Anand Avati <avati@redhat.com>

Comment 5 Anand Avati 2014-05-13 09:38:28 UTC
REVIEW: http://review.gluster.org/7748 (cluster/afr: Remove eager-lock stub on finodelk failure) posted (#1) for review on release-3.5 by Pranith Kumar Karampuri (pkarampu@redhat.com)

Comment 6 Anand Avati 2014-05-14 08:25:52 UTC
COMMIT: http://review.gluster.org/7748 committed in release-3.5 by Niels de Vos (ndevos@redhat.com) 
------
commit 4b2da260afb962c3411e75cb450e081e675e51ff
Author: Pranith Kumar K <pkarampu@redhat.com>
Date:   Tue May 13 14:49:47 2014 +0530

    cluster/afr: Remove eager-lock stub on finodelk failure
    
    Problem:
    For write fops afr's transaction eager-lock init adds transactions
    that can share eager-lock to fdctx list. But if eager-lock finodelk
    fop fails the stub remains in the list. This could later lead to
    corruption of the list and lead to infinite loop on the list
    leading to a mount hang.
    
    Fix:
    Remove the stub when finodelk fails.
    
    Change-Id: Ic9d1368907c32edb4ea2e6db623e869e4f50180d
    BUG: 1063190
    Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
    Reviewed-on: http://review.gluster.org/7748
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    Tested-by: Niels de Vos <ndevos@redhat.com>

Comment 7 Niels de Vos 2014-05-25 09:07:08 UTC
The first (and last?) Beta for GlusterFS 3.5.1 has been released [1]. Please verify if the release solves this bug report for you. In case the glusterfs-3.5.1beta release does not have a resolution for this issue, leave a comment in this bug and move the status to ASSIGNED. If this release fixes the problem for you, leave a note and change the status to VERIFIED.

Packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update (possibly an "updates-testing" repository) infrastructure for your distribution.

[1] http://supercolony.gluster.org/pipermail/gluster-users/2014-May/040377.html
[2] http://supercolony.gluster.org/pipermail/gluster-users/

Comment 8 Niels de Vos 2014-06-24 11:03:20 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.5.1, please reopen this bug report.

glusterfs-3.5.1 has been announced on the Gluster Users mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://supercolony.gluster.org/pipermail/gluster-users/2014-June/040723.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.