Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1063168 - Content is wrong when clicking a link on a filter result
Summary: Content is wrong when clicking a link on a filter result
Keywords:
Status: CLOSED DUPLICATE of bug 1062518
Alias: None
Product: Bugzilla
Classification: Community
Component: Reporting/Charting
Version: 4.4
Hardware: Unspecified
OS: Unspecified
high
medium vote
Target Milestone: 4.4
Assignee: PnT DevOps Devs
QA Contact: tools-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-10 07:53 UTC by Zhang Kexin
Modified: 2018-12-09 06:29 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-10 22:10:46 UTC


Attachments (Terms of Use)

Description Zhang Kexin 2014-02-10 07:53:55 UTC
Description of problem:
After clicking the link on "5"(last column and first line) on https://bugzilla.redhat.com/report.cgi?x_axis_field=priority&y_axis_field=qa_contact&z_axis_field=&no_redirect=1&query_format=report-table&short_desc_type=allwordssubstr&short_desc=&classification=Red+Hat&product=Red+Hat+Enterprise+Linux+7&bug_status=MODIFIED&bug_status=ON_QA&longdesc_type=allwordssubstr&longdesc=&bug_file_loc_type=allwordssubstr&bug_file_loc=&status_whiteboard_type=allwordssubstr&status_whiteboard=&keywords_type=allwords&keywords=&deadlinefrom=&deadlineto=&bug_id=&bug_id_type=anyexact&emailtype1=substring&email1=&emailtype2=substring&email2=&emailtype3=substring&email3=&chfieldvalue=&chfieldfrom=&chfieldto=Now&j_top=AND&f2=flagtypes.name&o2=substring&v2=7.0.0%2B&f4=qa_contact&o4=anywordssubstr&v4=haliu%40+jiali%40+eguan%40+jshao%40+zhchen%40+honli%40+cye%40+kzhang%40+ypei%40+huazhang%40+jinyang%40+jiyin%40+jipan%40+zlang%40+lxin%40+zshi%40+network-qe%40+fs-qe%40+infiniband-qe%40+weliu%40+xzhou%40&f5=cf_verified&o5=notsubstring&v5=SanityOnly&f6=OP&j6=OR&f7=priority&o7=anywordssubstr&v7=urgent+high&f8=keywords&o8=anywordssubstr&v8=futurefeature+regression+testblocker&f9=flagtypes.name&o9=substring&v9=blocker%2B&f10=noop&o10=noop&v10=&format=table&action=wrap

It gives wrong content:
https://bugzilla.redhat.com/buglist.cgi?action=wrap&bug_status=MODIFIED&bug_status=ON_QA&classification=Red%20Hat&f10=qa_contact&f2=flagtypes.name&f4=qa_contact&f5=cf_verified&f6=OP&f7=priority&f8=keywords&f9=flagtypes.name&j6=OR&list_id=2202525&o10=equals&o2=substring&o4=anywordssubstr&o5=notsubstring&o7=anywordssubstr&o8=anywordssubstr&o9=substring&product=Red%20Hat%20Enterprise%20Linux%207&v10=cye%40redhat.com&v2=7.0.0%2B&v4=haliu%40%20jiali%40%20eguan%40%20jshao%40%20zhchen%40%20honli%40%20cye%40%20kzhang%40%20ypei%40%20huazhang%40%20jinyang%40%20jiyin%40%20jipan%40%20zlang%40%20lxin%40%20zshi%40%20network-qe%40%20fs-qe%40%20infiniband-qe%40%20weliu%40%20xzhou%40&v5=SanityOnly&v7=urgent%20high&v8=futurefeature%20regression%20testblocker&v9=blocker%2B

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Described above
2.
3.

Actual results:
67 bugs with un-expected QA Contacts are given.

Expected results:
Only filter the 5 bugs with correct QA Contact.

Additional info:

Comment 1 Jason McDonald 2014-02-10 08:34:16 UTC
I can reproduce this issue.  Clicking a few other random links in the table gives similarly incorrect results.  The links appear to query for all QA contacts in the table, not just the one in the particular row the user clicked on.

Comment 2 Simon Green 2014-02-10 22:10:46 UTC

*** This bug has been marked as a duplicate of bug 1062518 ***


Note You need to log in before you can comment on or make changes to this bug.