Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1063139 - autofs regression test failure.
Summary: autofs regression test failure.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: autofs
Version: 7.0
Hardware: All
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Ian Kent
QA Contact: Yin.JianHong
URL:
Whiteboard:
Depends On:
Blocks: 1062567
TreeView+ depends on / blocked
 
Reported: 2014-02-10 06:15 UTC by Ian Kent
Modified: 2014-06-18 05:22 UTC (History)
2 users (show)

Fixed In Version: autofs-5.0.7-40.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-13 12:43:11 UTC


Attachments (Terms of Use)

Description Ian Kent 2014-02-10 06:15:42 UTC
Description of problem:
I've been investigating some autofs regression test failures
that were reported to me by QE.

One is the autofs regression test bz239361 which fails due to
changes needed in the autofs rpc code.

Version-Release number of selected component (if applicable):
autofs-5.0.7-39

How reproducible:
Only when multiple mount locations must be probed using the
autofs rpc library code.

Steps to Reproduce:
1. bkr workflow-autofs --arch=x86_64 \
        --distro=RHEL-7.0-20140130.n.0 \
        --variant=Server --subtask=bz239361

As far as I can see the issue isn't restricted only to
RHEL-7.0-20140130.n.0.

Actual results:
The availability probing doesn't work properly resulting
in the test failing.

Expected results:
Test succeeds.

Additional info:
There are some changes in Fedora that appear to fix this
problem. They need to be applied and further testing done.

Comment 2 Yin.JianHong 2014-02-25 07:52:36 UTC
verified test PASS
  https://beaker.engineering.redhat.com/jobs/598870

Comment 3 Ludek Smid 2014-06-13 12:43:11 UTC
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.


Note You need to log in before you can comment on or make changes to this bug.