Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1063105 - Please change the order of author name and remove [FAMILY Given]
Summary: Please change the order of author name and remove [FAMILY Given]
Keywords:
Status: CLOSED DUPLICATE of bug 1150866
Alias: None
Product: Publican
Classification: Community
Component: publican-redhat
Version: 4.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ruediger Landmann
QA Contact: Jeff Fearn 🐞
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-10 02:20 UTC by Yuko Katabami
Modified: 2014-10-14 03:59 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-14 03:59:59 UTC


Attachments (Terms of Use)
Example cover page showing author names (deleted)
2014-02-10 02:21 UTC, Yuko Katabami
no flags Details

Description Yuko Katabami 2014-02-10 02:20:02 UTC
Description of problem:
When building a document with ja-JP specified, name enclosed in <author> tags are shown in order of 
1. Surname 
2. First name
and the text [FAMILY Given] is added at the end of the name.

English author names do not need to be in this order in our language.
It should be same as English.
Also the general Japanese readers would not understand what [FAMILY Given] is for.

Version-Release number of selected component (if applicable): 4.0


How reproducible: 100%


Steps to Reproduce:
1. Build a book with "--lang ja-JP" option specified
2. Check the cover page to see how names are displayed


Actual results:
(Surname) (First name) [FAMILY Given]

Expected results:
(First name) (Surname)

Additional info:

Comment 1 Yuko Katabami 2014-02-10 02:21:19 UTC
Created attachment 861217 [details]
Example cover page showing author names

Comment 2 Yuko Katabami 2014-02-10 02:41:55 UTC
According to Rudi, the text [FAMILY Given] is removed and this solved one problem, however change of the order is not fixed yet.

The project I am currently working on is due to be published in mid March and I would like the order to be fixed since there is a bug in the doc being affected by this.

It would be very much appreciated if you could also take action on the order by early March, so that I will be able to publish the book.

Many thanks in advance.

Comment 3 Ruediger Landmann 2014-02-10 06:13:33 UTC
Name order changed and [FAMILY Given] removed in the various brands as follows:

* publican-rhev-3.2-1.el6eng
* publican-redhat-db5-4.2-2.el6eng
* publican-redhat-4.3-1.el6eng
* publican-openshift-1.2-1.el6eng
* publican-jboss-4.2-1.el6eng

Comment 4 Ruediger Landmann 2014-02-17 04:50:19 UTC
Reopening because epub is not solved yet

Comment 5 Yuko Katabami 2014-07-28 09:36:13 UTC
I just found that PDF has not been solved either.
Please check.

Comment 6 Yuko Katabami 2014-07-28 09:36:25 UTC
I just found that PDF has not been solved either.
Please check.

Comment 7 Ruediger Landmann 2014-10-14 03:59:59 UTC

*** This bug has been marked as a duplicate of bug 1150866 ***


Note You need to log in before you can comment on or make changes to this bug.