Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1063059 - WARNING: CPU: 1 PID: 3772 at lib/dma-debug.c:491 add_dma_entry+0x127/0x130()
Summary: WARNING: CPU: 1 PID: 3772 at lib/dma-debug.c:491 add_dma_entry+0x127/0x130()
Keywords:
Status: CLOSED DUPLICATE of bug 1062833
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-09 18:21 UTC by poma
Modified: 2014-02-13 13:48 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-13 13:48:58 UTC


Attachments (Terms of Use)

Description poma 2014-02-09 18:21:34 UTC
Domain;
/etc/libvirt/qemu/<domain>.xml:
<domain type='kvm'>
  <os>
    <type arch='x86_64' machine='pc-i440fx-1.6'>hvm</type>
  </os>
  <devices>
    <emulator>/usr/bin/qemu-kvm</emulator>
    <disk type='file' device='disk'>
      <driver name='qemu' type='qcow2'/>
      <source file='/var/lib/libvirt/images/rawhide209.img'/>
      <target dev='sda' bus='sata'/>
      <address type='drive' controller='0' bus='0' target='0' unit='0'/>
    </disk>
    <controller type='sata' index='0'>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x09' function='0x0'/>
    </controller>
  </devices>
</domain>

lspci:
00:09.0 SATA controller [0106]: Intel Corporation 82801IR/IO/IH (ICH9R/DO/DH) 6 port SATA Controller [AHCI mode] [8086:2922] (rev 02)

[  456.462913] ------------[ cut here ]------------
[  456.462926] WARNING: CPU: 1 PID: 3772 at lib/dma-debug.c:491 add_dma_entry+0x127/0x130()
[  456.462928] DMA-API: exceeded 7 overlapping mappings of pfn 2137
[  456.462930] Modules linked in: xfs libcrc32c btrfs fcoe libfcoe libfc scsi_transport_fc scsi_tgt iscsi_ibft iscsi_boot_sysfs iscsi_tcp libiscsi_tcp libiscsi scsi_transport_iscsi dm_crypt vfat fat dm_round_robin dm_multipath raid10 raid456 async_raid6_recov async_memcpy async_pq raid6_pq async_xor xor async_tx raid1 raid0 uinput ip6t_rpfilter ip6t_REJECT xt_conntrack cfg80211 rfkill ebtable_nat ebtable_broute bridge stp llc ebtable_filter ebtables ip6table_nat nf_conntrack_ipv6 nf_defrag_ipv6 nf_nat_ipv6 ip6table_mangle ip6table_security ip6table_raw ip6table_filter ip6_tables iptable_nat nf_conntrack_ipv4 nf_defrag_ipv4 nf_nat_ipv4 nf_nat nf_conntrack iptable_mangle iptable_security iptable_raw ppdev kvm joydev serio_raw snd_hda_intel virtio_console snd_hda_codec snd_hwdep snd_seq snd_seq_device
[  456.462997]  snd_pcm parport_pc pvpanic snd_timer parport snd soundcore i2c_piix4 nfsd auth_rpcgss nfs_acl lockd isofs squashfs virtio_balloon virtio_net qxl sym53c8xx drm_kms_helper scsi_transport_spi ttm drm virtio_pci virtio_ring ata_generic i2c_core virtio pata_acpi sunrpc loop
[  456.463039] CPU: 1 PID: 3772 Comm: ext4lazyinit Not tainted 3.14.0-0.rc1.git3.1.fc21.x86_64 #1
[  456.463042] Hardware name: Bochs Bochs, BIOS Bochs 01/01/2011
[  456.463044]  0000000000000000 0000000084feec1b ffff88001c861898 ffffffff817cee9d
[  456.463049]  ffff88001c8618e0 ffff88001c8618d0 ffffffff810967cd 0000000000002137
[  456.463053]  ffff88007288d540 0000000000000096 ffffffff82d645c0 0000000000000096
[  456.463056] Call Trace:
[  456.463063]  [<ffffffff817cee9d>] dump_stack+0x4d/0x66
[  456.463068]  [<ffffffff810967cd>] warn_slowpath_common+0x7d/0xa0
[  456.463071]  [<ffffffff8109684c>] warn_slowpath_fmt+0x5c/0x80
[  456.463075]  [<ffffffff813f373d>] ? active_pfn_read_overlap+0x2d/0x50
[  456.463079]  [<ffffffff813f3d07>] add_dma_entry+0x127/0x130
[  456.463082]  [<ffffffff813f43dd>] debug_dma_map_sg+0x13d/0x180
[  456.463086]  [<ffffffff8153f0c1>] ata_qc_issue+0x281/0x3e0
[  456.463090]  [<ffffffff81548395>] ata_scsi_queuecmd+0x135/0x420
[  456.463094]  [<ffffffff81545150>] ? ata_scsi_invalid_field+0x40/0x40
[  456.463098]  [<ffffffff8151b777>] scsi_dispatch_cmd+0xb7/0x4e0
[  456.463101]  [<ffffffff81523bcc>] scsi_request_fn+0x33c/0x540
[  456.463106]  [<ffffffff813956f3>] __blk_run_queue+0x33/0x40
[  456.463109]  [<ffffffff8139b913>] blk_queue_bio+0x343/0x4d0
[  456.463113]  [<ffffffff81395510>] generic_make_request+0xe0/0x130
[  456.463116]  [<ffffffff813955d8>] submit_bio+0x78/0x160
[  456.463121]  [<ffffffff81273628>] ? bio_alloc_bioset+0x1f8/0x2f0
[  456.463125]  [<ffffffff813a311f>] __blkdev_issue_zeroout+0x1ff/0x260
[  456.463129]  [<ffffffff813a3269>] blkdev_issue_zeroout+0xe9/0xf0
[  456.463133]  [<ffffffff81303d9e>] ? __ext4_journal_get_write_access+0x4e/0x90
[  456.463137]  [<ffffffff812ccc1c>] ext4_init_inode_table+0x17c/0x3c0
[  456.463142]  [<ffffffff812e2039>] ? ext4_lazyinit_thread+0xb9/0x320
[  456.463145]  [<ffffffff812e222d>] ext4_lazyinit_thread+0x2ad/0x320
[  456.463149]  [<ffffffff812e1f80>] ? ext4_unregister_li_request+0x70/0x70
[  456.463153]  [<ffffffff810c43ef>] kthread+0xff/0x120
[  456.463156]  [<ffffffff810c42f0>] ? insert_kthread_work+0x80/0x80
[  456.463160]  [<ffffffff817e2c3c>] ret_from_fork+0x7c/0xb0
[  456.463163]  [<ffffffff810c42f0>] ? insert_kthread_work+0x80/0x80
[  456.463165] ---[ end trace d1e41b42a5f51fa8 ]---

https://bugzilla.redhat.com/attachment.cgi?id=861122

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Bare metal;

lspci:
00:09.0 SATA controller [0106]: NVIDIA Corporation MCP78S [GeForce 8200] AHCI Controller [10de:0ad4] (rev a2)

[   72.012408] ------------[ cut here ]------------
[   72.012418] WARNING: CPU: 0 PID: 9502 at lib/dma-debug.c:554 debug_dma_assert_idle+0xc4/0x140()
[   72.012420] ahci 0000:00:09.0: DMA-API: cpu touching an active dma mapped page [pfn=0x943ba]
[   72.012421] Modules linked in: ipt_MASQUERADE iptable_nat nf_nat_ipv4 nf_nat nf_conntrack_ipv4 nf_defrag_ipv4 xt_conntrack nf_conntrack xt_CHECKSUM iptable_mangle fuse ip6table_filter ip6_tables ebtable_nat ebtables kvm_amd kvm ppdev microcode serio_raw nouveau mxm_wmi video i2c_algo_bit ttm edac_core edac_mce_amd drm_kms_helper k10temp drm parport_serial parport_pc parport wmi shpchp i2c_nforce2 i2c_core acpi_cpufreq nfsd auth_rpcgss nfs_acl lockd sunrpc binfmt_misc ata_generic pata_acpi pata_amd 8021q garp mrp tun bridge stp llc bonding
[   72.012542] CPU: 0 PID: 9502 Comm: ld-linux-x86-64 Not tainted 3.14.0-0.rc1.git5.1.fc21.1.x86_64 #1
[   72.012544] Hardware name: Gigabyte Technology Co., Ltd. M720-US3/M720-US3, BIOS F7n 09/07/2010
[   72.012546]  0000000000000000 00000000ff75c10e ffff8800970f3c48 ffffffff817cf05d
[   72.012550]  ffff8800970f3c90 ffff8800970f3c80 ffffffff810966cd ffff8800c8dd7600
[   72.012553]  ffff8801286c2f40 00000000000943ba ffffea000255cc00 ffff8800b0756058
[   72.012556] Call Trace:
[   72.012561]  [<ffffffff817cf05d>] dump_stack+0x4d/0x66
[   72.012565]  [<ffffffff810966cd>] warn_slowpath_common+0x7d/0xa0
[   72.012567]  [<ffffffff8109674c>] warn_slowpath_fmt+0x5c/0x80
[   72.012571]  [<ffffffff810f899d>] ? trace_hardirqs_on+0xd/0x10
[   72.012573]  [<ffffffff813f5b24>] debug_dma_assert_idle+0xc4/0x140
[   72.012576]  [<ffffffff811de8b4>] do_wp_page+0xf4/0x7f0
[   72.012578]  [<ffffffff811e130c>] handle_mm_fault+0x66c/0xe90
[   72.012582]  [<ffffffff817dce53>] __do_page_fault+0x183/0x600
[   72.012585]  [<ffffffff810246c5>] ? native_sched_clock+0x35/0xa0
[   72.012588]  [<ffffffff81024739>] ? sched_clock+0x9/0x10
[   72.012590]  [<ffffffff810dd465>] ? local_clock+0x25/0x30
[   72.012593]  [<ffffffff810f5c6f>] ? lock_release_holdtime.part.29+0xf/0x190
[   72.012595]  [<ffffffff817d9018>] ? retint_swapgs+0x13/0x1b
[   72.012598]  [<ffffffff813d55da>] ? trace_hardirqs_off_thunk+0x3a/0x3c
[   72.012601]  [<ffffffff817dd2de>] do_page_fault+0xe/0x10
[   72.012603]  [<ffffffff817d9338>] page_fault+0x28/0x30
[   72.012605] ---[ end trace 48bb75765e35d9de ]---
[   72.012606] Mapped at:
[   72.012607]  [<ffffffff813f42f9>] debug_dma_map_sg+0x159/0x180
[   72.012609]  [<ffffffff8153f151>] ata_qc_issue+0x281/0x3e0
[   72.012613]  [<ffffffff81548425>] ata_scsi_queuecmd+0x135/0x420
[   72.012616]  [<ffffffff8151b807>] scsi_dispatch_cmd+0xb7/0x4e0
[   72.012619]  [<ffffffff81523c5c>] scsi_request_fn+0x33c/0x540

Comment 1 Stanislaw Gruszka 2014-02-13 13:48:58 UTC

*** This bug has been marked as a duplicate of bug 1062833 ***


Note You need to log in before you can comment on or make changes to this bug.