Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1063004 - crash on spice connect with viewer 0.6.0 Windows gtk3 build
Summary: crash on spice connect with viewer 0.6.0 Windows gtk3 build
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Virtualization Tools
Classification: Community
Component: virt-viewer
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Daniel Berrange
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-09 14:39 UTC by Markus Stockhausen
Modified: 2015-08-24 16:36 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-24 16:36:25 UTC


Attachments (Terms of Use)
crash (deleted)
2014-02-09 14:39 UTC, Markus Stockhausen
no flags Details

Description Markus Stockhausen 2014-02-09 14:39:21 UTC
Description of problem:

virt-viewer with gtk3 build crashes directly after spice connection.


Version-Release number of selected component (if applicable):

virt-viewer 0.6.0

How reproducible:

100%

Steps to Reproduce:

1. compile virt-viewer 0.6.0 with gtk3 for Windows 

2. install virt-viewer

3. connect to spice server (e.g. OVirt)

Actual results:

virt-viewer crashes

Expected results:

Spice console should be displayed.

Additional info:

Crash occurs in gdk_window_get_type. See screenshot.

Comment 1 Markus Stockhausen 2014-02-09 14:39:57 UTC
Created attachment 861044 [details]
crash

Comment 2 Pavel Grunt 2015-08-24 16:36:25 UTC
should be fixed since spice-gtk v0.27 which contained a lot of gtk3 related fixes


Note You need to log in before you can comment on or make changes to this bug.