Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1062973 - 3.2 channel should not be disabled before upgrade
Summary: 3.2 channel should not be disabled before upgrade
Keywords:
Status: CLOSED DUPLICATE of bug 1062793
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: Documentation
Version: 3.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Andrew Dahms
QA Contact: ecs-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-09 11:03 UTC by Yedidyah Bar David
Modified: 2014-03-25 07:11 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Build Name: 12875, Installation Guide-3.3-6 Build Date: 09-01-2014 16:06:08 Topic ID: 22421-574531 [Latest]
Last Closed: 2014-02-10 23:23:30 UTC
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)

Description Yedidyah Bar David 2014-02-09 11:03:59 UTC
Title: Upgrading to Red Hat Enterprise Virtualization Manager 3.3

Describe the issue:

section 6.2.3 instructs to disable the 3.2 channel before upgrading the engine to 3.3.

This has two problems:
1. It causes errors related to dependencies/locking/etc., e.g. bug #1062774 .
2. It prevents rollback.

(2.) is especially important. Even if we somehow manage to solve all such and similar errors, and make the upgrade finish smoothly, we definitely do not want to disable 3.2 - because this will prevent downgrading gracefully back to 3.2 in case there is some problem during the upgrade. 'engine-setup' supports such a downgrade, but this is not possible if the 3.2 channel is disabled.

Comment 2 Andrew Dahms 2014-02-10 23:23:30 UTC
Hi Yedidyah,

Thank you for raising this bug.

I have had a look at this bug and am working on the changes now.
Because Bug #1062793 was raised before this bug, I will close this bug and handle all further contact in Bug #1062793.

*** This bug has been marked as a duplicate of bug 1062793 ***


Note You need to log in before you can comment on or make changes to this bug.