Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1062955 - DOC: document that per-interface sysctl variables are applied on hotplug
Summary: DOC: document that per-interface sysctl variables are applied on hotplug
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: systemd
Version: 19
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: systemd-maint
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-09 08:43 UTC by udo
Modified: 2014-08-08 08:40 UTC (History)
7 users (show)

Fixed In Version: systemd-204-20.fc19
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-08 08:40:51 UTC


Attachments (Terms of Use)

Description udo 2014-02-09 08:43:10 UTC
Description of problem:
When doing ifup on an interface, systemd-sysctl appears to fiddle with my sysctl settings without telling me what setting, why it happens, how it is changing. This without asking or explaining why.

Version-Release number of selected component (if applicable):
systemd-204-18.fc19.i686

How reproducible:
See below.

Steps to Reproduce:
See below.

Actual results:
# ifup eth1.6
Overwriting earlier assignment of kernel/sysrq in file '/etc/sysctl.conf'.

Expected results:
# ifup eth1.6
#

Additional info:
If there is a need for systemd doing even more stuff than init ever did, please make it even more clear why that is needed, how it works, how it can be configured and how it can be turned off. As the simplest of changes take ages to complete (swapping, logging, etc) I know what I am in for.

Comment 1 Lennart Poettering 2014-02-23 15:44:32 UTC
The network interface specific sysctl options are applied when the network interfaces show up. This is necessary to make sure they are applied without races, as applying them solely at early boot would not work because there's no guarantee that the interfaces have shown up at that point and hence whether they would be applied at all.

It is ture that this behaviour is currently not documented. I have now made a change to git accordingly.

http://cgit.freedesktop.org/systemd/systemd/commit/?id=8f03fd08911016d8bbcad5892b2c07b30a4c2306

Comment 2 udo 2014-02-23 15:52:18 UTC
How did we ever get by without this?

Comment 3 Fedora Update System 2014-07-23 03:55:14 UTC
systemd-204-20.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/systemd-204-20.fc19

Comment 4 Fedora Update System 2014-07-24 03:21:13 UTC
Package systemd-204-20.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing systemd-204-20.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-8761/systemd-204-20.fc19
then log in and leave karma (feedback).

Comment 5 Fedora Update System 2014-08-08 08:40:51 UTC
systemd-204-20.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.