Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1062951 - Mouse sometimes double-clicks when I intend to single-click
Summary: Mouse sometimes double-clicks when I intend to single-click
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-evdev
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-09 06:26 UTC by Aram Agajanian
Modified: 2014-02-13 04:08 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-11 16:41:10 UTC


Attachments (Terms of Use)
output of "evemu-describe /dev/input/event3" on my home computer (deleted)
2014-02-11 04:12 UTC, Aram Agajanian
no flags Details
output of "evemu-record /dev/input/event3" when attempting to select text and the highlighting disappears (deleted)
2014-02-11 13:32 UTC, Aram Agajanian
no flags Details

Description Aram Agajanian 2014-02-09 06:26:50 UTC
Description of problem:
I have a Dell mouse which often seems to double-click when I intend to single-click.  (See the following lsusb output.) 

Bus 005 Device 003: ID 413c:3012 Dell Computer Corp. Optical Wheel Mouse

I especially notice this when I try to highlight text. The highlighting keeps disappearing due to the double-clicks that are registered when I try to single-click.


Version-Release number of selected component (if applicable):
xorg-x11-drv-evdev-2.8.2-1.fc20.x86_64

How reproducible:
The irregular double-click behavior seems to happen every time I use Fedora 20 with this mouse.  However, the reaction of the computer to a mouse click is seemingly random.
Steps to Reproduce:
1.  Boot Fedora 20 with Dell mouse attached.
2.  Try clicking on parts of the UI.

Actual results:
A single click of the mouse button is sometimes responded to as a double-click.

Expected results:
A single click of the mouse button should always be responded to as a single-click.

Additional info:
I also have a Logitech MX310 mouse.  I do not encounter this problem with the Logitech mouse.  However, the Logitech mouse seems to be unable to right-click in Fedora 20.

I don't think that this is a hardware problem because I didn't encounter this problem before Fedora 20.

I have a different model Dell mouse at work and it seems to have the same problem.

See also the mailing list post at the following URL which describes a similar problem.

http://www.spinics.net/linux/fedora/fedora-users/msg444842.html

Comment 1 Aram Agajanian 2014-02-10 22:25:22 UTC
I can't seem to recreate this problem on my work computer any more.  It seems to be happening only on my home computer.

Comment 2 Peter Hutterer 2014-02-11 02:18:22 UTC
run evemu-describe against the device when this happens. this should show you what's coming out of the kernel and narrow down if this is a kernel or Xorg issue. also check the kernel version on your work computer and see if updating helps.

Comment 3 Aram Agajanian 2014-02-11 04:12:54 UTC
Created attachment 861656 [details]
output of "evemu-describe /dev/input/event3" on my home computer

This issue persists when using the latest kernel (3.12.10-300.fc20.x86_64).  evemu-describe was run after booting with that kernel.

Comment 4 Aram Agajanian 2014-02-11 13:32:22 UTC
Created attachment 861785 [details]
output of "evemu-record /dev/input/event3" when attempting to select text and the highlighting disappears

Comment 5 Hans de Goede 2014-02-11 13:56:56 UTC
Hi,

(In reply to Aram Agajanian from comment #4)
> Created attachment 861785 [details]
> output of "evemu-record /dev/input/event3" when attempting to select text
> and the highlighting disappears

Looking at the trace, it seems that the button bounces when you let go of it, the left button state goes like this:

press
-pressed movement, I assume the selecting of the text
release
press
release

With the last 3 happening within 25ms of each other, so it seems that your left mouse button is simply worn out and is bouncing so badly that the debouncing logic built into the mouse cannot cope with it. Note that all physical buttons always bounce, see: http://en.wikipedia.org/wiki/Switch#Contact_bounce

I know you've indicated this happened after an upgrade, but I find this highly unlikely. It really does look like your mouse is simply defect.

Regards,

Hans

Comment 6 Aram Agajanian 2014-02-11 16:29:48 UTC
> I know you've indicated this happened after an upgrade, but I find this
> highly unlikely. It really does look like your mouse is simply defect.

Thanks for your help.  Perhaps the problem just got worse lately.  The computer is under warranty so I'll ask for another mouse.

Comment 7 Hans de Goede 2014-02-11 16:41:10 UTC
(In reply to Aram Agajanian from comment #6)
> > I know you've indicated this happened after an upgrade, but I find this
> > highly unlikely. It really does look like your mouse is simply defect.
> 
> Thanks for your help.  Perhaps the problem just got worse lately.  The
> computer is under warranty so I'll ask for another mouse.

I'm going to close this as resolved then, if you see the problem with another mouse, please re-open this bug and we'll investigate this issue further.


Note You need to log in before you can comment on or make changes to this bug.