Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1062941 - Zenity does not expand lists views correctly
Summary: Zenity does not expand lists views correctly
Keywords:
Status: CLOSED DUPLICATE of bug 1022949
Alias: None
Product: Fedora
Classification: Fedora
Component: zenity
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1084768
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-09 01:33 UTC by Davide Repetto
Modified: 2014-05-01 14:29 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-05-01 14:29:44 UTC


Attachments (Terms of Use)

Description Davide Repetto 2014-02-09 01:33:51 UTC
Description of problem:
=======================
Zenity does not expand list views correctly. It will generate list viewsof 1-3 rows max even though the main window height is much larger.
https://bugzilla.gnome.org/show_bug.cgi?id=721604
https://bugzilla.gnome.org/show_bug.cgi?id=702535

There is a simple one line fix upstream:
========================================
https://git.gnome.org/browse/zenity/commit/?id=80bc8ce643979fec201c4ebd5cd6405b6310357f


It would be nice to have a build with this fix for Fedora.

Additional Info: (Upstream Patch)

diff --git a/src/zenity.ui b/src/zenity.ui
index ee89093..7c0ab1f 100644
--- a/src/zenity.ui
+++ b/src/zenity.ui
@@ -1021,6 +1021,7 @@
                 <property name="visible">True</property>
                 <property name="can_focus">True</property>
                 <property name="shadow_type">in</property>
+                <property name="expand">True</property>
                 <child>
                   <object class="GtkTreeView" id="zenity_tree_view">
                     <property name="visible">True</property>

Comment 1 Christian Klomp 2014-02-28 19:33:52 UTC
I would also really like to have this fixed for F20.
It is really a hassle to work with Winetricks now.
https://groups.google.com/forum/#!topic/winetricks-dev/82b5ThhdQvo

Comment 2 Ville Skyttä 2014-05-01 14:29:44 UTC

*** This bug has been marked as a duplicate of bug 1022949 ***


Note You need to log in before you can comment on or make changes to this bug.