Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1062940 - [abrt] system-config-printer: printerproperties.py:1579:updateMarkerLevels:UnicodeEncodeError: 'ascii' codec can't encode character u'\xf3' in position 1: ordinal not in range(128)
Summary: [abrt] system-config-printer: printerproperties.py:1579:updateMarkerLevels:Un...
Keywords:
Status: CLOSED DUPLICATE of bug 1046466
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-printer
Version: 20
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:a6c72cde6a411803f2c507f524d...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-09 01:25 UTC by Hipolito Fuentes
Modified: 2014-02-10 12:18 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-10 12:18:31 UTC


Attachments (Terms of Use)
File: backtrace (deleted)
2014-02-09 01:26 UTC, Hipolito Fuentes
no flags Details
File: environ (deleted)
2014-02-09 01:26 UTC, Hipolito Fuentes
no flags Details

Description Hipolito Fuentes 2014-02-09 01:25:56 UTC
Version-Release number of selected component:
system-config-printer-1.4.3-2.fc20

Additional info:
reporter:       libreport-2.1.12
cmdline:        /usr/bin/python /usr/share/system-config-printer/system-config-printer.py
dso_list:       system-config-printer-libs-1.4.3-2.fc20.noarch
executable:     /usr/share/system-config-printer/system-config-printer.py
kernel:         3.12.9-301.fc20.x86_64
runlevel:       N 5
type:           Python
uid:            1000

Truncated backtrace:
printerproperties.py:1579:updateMarkerLevels:UnicodeEncodeError: 'ascii' codec can't encode character u'\xf3' in position 1: ordinal not in range(128)

Traceback (most recent call last):
  File "/usr/share/system-config-printer/printerproperties.py", line 1909, in on_printer_event
    self.on_printer_modified (None, printer, False)
  File "/usr/share/system-config-printer/printerproperties.py", line 1899, in on_printer_modified
    self.updatePrinterProperties ()
  File "/usr/share/system-config-printer/printerproperties.py", line 1685, in updatePrinterProperties
    self.updateMarkerLevels ()
  File "/usr/share/system-config-printer/printerproperties.py", line 1579, in updateMarkerLevels
    localized_name = self.ppd.localizeMarkerName(name)
UnicodeEncodeError: 'ascii' codec can't encode character u'\xf3' in position 1: ordinal not in range(128)

Local variables in innermost frame:
widget: <Label object at 0x4b6fd70 (GtkLabel at 0x4a18570)>
rows: 1
name: u'T\xf3ner'
val: [-1, -1]
level: -1
color: u'#000000'
self: <PrinterPropertiesDialog object at 0x2f956e0 (printerproperties+PrinterPropertiesDialog at 0x30cd780)>
num_markers: 0
cols: 2
markers: [(u'#000000', u'T\xf3ner', u'toner', -1), (u'#000000', u'T\xf3ner residual', u'waste-toner', -1)]
marker_info: {'marker-names': [u'T\xf3ner', u'T\xf3ner residual'], 'marker-types': [u'toner', u'waste-toner'], 'marker-levels': [-1, -1], 'marker-colors': [u'#000000', u'#000000']}
printer: <cupshelpers.Printer "Ricoh-Aficio-MP-5000B">
can_refresh: True
marker_type: u'toner'
table: <Table object at 0x4b6fbe0 (GtkTable at 0x4885cc0)>
typ: <type 'float'>
attr: 'marker-levels'

Comment 1 Hipolito Fuentes 2014-02-09 01:26:00 UTC
Created attachment 860925 [details]
File: backtrace

Comment 2 Hipolito Fuentes 2014-02-09 01:26:02 UTC
Created attachment 860926 [details]
File: environ

Comment 3 Tim Waugh 2014-02-10 12:18:31 UTC

*** This bug has been marked as a duplicate of bug 1046466 ***


Note You need to log in before you can comment on or make changes to this bug.