Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1062873 - NetworkManager icon shows up every now and then
Summary: NetworkManager icon shows up every now and then
Keywords:
Status: CLOSED EOL
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-shell
Version: 22
Hardware: i686
OS: Linux
low
low
Target Milestone: ---
Assignee: Owen Taylor
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1063066 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-08 10:10 UTC by Ali Akcaagac
Modified: 2016-07-19 20:51 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-19 20:51:46 UTC


Attachments (Terms of Use)
Screenshot showing the issues. (deleted)
2014-02-08 10:10 UTC, Ali Akcaagac
no flags Details
No network icon in gnome shell, while network connected, F-22 (deleted)
2015-04-29 23:01 UTC, Bojan Smojver
no flags Details
No network icon with F-23, while connected to wired (deleted)
2015-11-12 23:53 UTC, Bojan Smojver
no flags Details

Description Ali Akcaagac 2014-02-08 10:10:19 UTC
Created attachment 860856 [details]
Screenshot showing the issues.

I am under Fedora 20. Installation from CD and using all recent updates. Whenever I log into gnome-shell the top icon for NetworkManager is missing. Sometimes it shows up, sometimes it won't. The icon is there. As soon as I restart gnome-shell, the icon shows up again. But it would be nice to have the icon appear the first time I log into gnome-shell. Attached a screenshot explaining the issue.

Comment 1 Jirka Klimes 2014-02-11 11:20:41 UTC
It is most probably an gnome-shell issue.

Nonetheless, when an icon is missing could you check whether NM is running? Run e.g.:
$ ps aux | grep NetworkManager
$ nmcli -f all general

Comment 2 Jirka Klimes 2014-02-11 11:26:25 UTC
*** Bug 1063066 has been marked as a duplicate of this bug. ***

Comment 3 Ali Akcaagac 2014-02-11 11:44:40 UTC
I forgot to mention that WLAN connected properly otherwise I wouldn't be connected to "Xayde" my SSID (as shown in the screenhot). I belive it's a timing issue e.g. what was there first. gnome-shell or networkmanager applet.

Comment 4 Ali Akcaagac 2015-03-08 15:19:45 UTC
Due of duplication this can be closed as it is fixed already.

Comment 5 Bojan Smojver 2015-04-29 22:58:56 UTC
Yeah, still a problem in F-21 and F-22.

On this particular laptop, I have wired network connected and icon sometimes shows, sometimes does not. On a remote VM (also wired), it mostly shows, but even there it sometimes disappears.

Occasionally, the icon also changes to ?, although the network is connected and working properly.

Comment 6 Bojan Smojver 2015-04-29 23:01:03 UTC
Created attachment 1020364 [details]
No network icon in gnome shell, while network connected, F-22

Clearly, I would not be able to post this screenshot without the network being up.

Comment 7 Bojan Smojver 2015-05-18 08:00:06 UTC
(In reply to Bojan Smojver from comment #5)

> Occasionally, the icon also changes to ?, although the network is connected
> and working properly.

Don't worry about this bit - that was the consequence of having installed workstation package, which phones home every so often. I've since removed this package.

The other problem still occasionally occurs - no network icon at all.

Comment 8 Ali Akcaagac 2015-11-12 15:08:18 UTC
I am wondering if this is still happening ? A bunch of updates might have solved the issue ?

Comment 9 Bojan Smojver 2015-11-12 20:16:28 UTC
I still get this from time to time, even on F-23.

Comment 10 Bojan Smojver 2015-11-12 23:53:21 UTC
Created attachment 1093493 [details]
No network icon with F-23, while connected to wired

Comment 11 Fedora End Of Life 2016-07-19 20:51:46 UTC
Fedora 22 changed to end-of-life (EOL) status on 2016-07-19. Fedora 22 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.