Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1062752 - TypeError: argument iter: Expected Gtk.TreeIter, but got int
Summary: TypeError: argument iter: Expected Gtk.TreeIter, but got int
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda
Version: 7.0
Hardware: x86_64
OS: Unspecified
urgent
urgent
Target Milestone: rc
: ---
Assignee: Chris Lumens
QA Contact: Release Test Team
URL:
Whiteboard: abrt_hash:a15855e528d70578fd0d6e71191...
Depends On: 1070854
Blocks: 782468
TreeView+ depends on / blocked
 
Reported: 2014-02-07 22:08 UTC by Jeff Bastian
Modified: 2019-04-08 14:34 UTC (History)
8 users (show)

Fixed In Version: anaconda-19.31.63-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-13 09:38:31 UTC


Attachments (Terms of Use)
File: anaconda-tb (deleted)
2014-02-07 22:08 UTC, Jeff Bastian
no flags Details
File: anaconda.log (deleted)
2014-02-07 22:09 UTC, Jeff Bastian
no flags Details
File: environ (deleted)
2014-02-07 22:09 UTC, Jeff Bastian
no flags Details
File: lsblk_output (deleted)
2014-02-07 22:09 UTC, Jeff Bastian
no flags Details
File: nmcli_dev_list (deleted)
2014-02-07 22:09 UTC, Jeff Bastian
no flags Details
File: os_info (deleted)
2014-02-07 22:09 UTC, Jeff Bastian
no flags Details
File: program.log (deleted)
2014-02-07 22:09 UTC, Jeff Bastian
no flags Details
File: storage.log (deleted)
2014-02-07 22:09 UTC, Jeff Bastian
no flags Details
File: syslog (deleted)
2014-02-07 22:09 UTC, Jeff Bastian
no flags Details
File: ifcfg.log (deleted)
2014-02-07 22:09 UTC, Jeff Bastian
no flags Details
File: packaging.log (deleted)
2014-02-07 22:09 UTC, Jeff Bastian
no flags Details
anaconda.log (deleted)
2014-02-25 23:06 UTC, IBM Bug Proxy
no flags Details
program log (deleted)
2014-02-25 23:06 UTC, IBM Bug Proxy
no flags Details
storage log (deleted)
2014-02-25 23:06 UTC, IBM Bug Proxy
no flags Details
anaconda-tb (deleted)
2014-02-25 23:06 UTC, IBM Bug Proxy
no flags Details

Description Jeff Bastian 2014-02-07 22:08:56 UTC
Description of problem:
I'm trying to install RHEL 7 on a system and I configured it to use btrfs for / and /home.  I changed the size on the btrfs volume from the automatic setting to a manual setting of 200 GB and anaconda crashed.

Version-Release number of selected component:
anaconda-19.31.56-1

The following was filed automatically by anaconda:
anaconda 19.31.56-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/gi/types.py", line 113, in function
    return info.invoke(*args, **kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 2456, in on_modify_container_clicked
    self._containerStore.remove(idx)
TypeError: argument iter: Expected Gtk.TreeIter, but got int

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=/images/pxeboot/vmlinuz inst.stage2=hd:LABEL=RHEL-7.0\x20x86_64 quiet
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.10.0-84.el7.x86_64
product:        Red Hat Enterprise Linux
release:        Red Hat Enterprise Linux Client release 7.0 Beta (Maipo)
type:           anaconda
version:        7.0

Comment 1 Jeff Bastian 2014-02-07 22:08:58 UTC
Created attachment 860716 [details]
File: anaconda-tb

Comment 2 Jeff Bastian 2014-02-07 22:09:00 UTC
Created attachment 860717 [details]
File: anaconda.log

Comment 3 Jeff Bastian 2014-02-07 22:09:01 UTC
Created attachment 860718 [details]
File: environ

Comment 4 Jeff Bastian 2014-02-07 22:09:02 UTC
Created attachment 860719 [details]
File: lsblk_output

Comment 5 Jeff Bastian 2014-02-07 22:09:04 UTC
Created attachment 860720 [details]
File: nmcli_dev_list

Comment 6 Jeff Bastian 2014-02-07 22:09:05 UTC
Created attachment 860721 [details]
File: os_info

Comment 7 Jeff Bastian 2014-02-07 22:09:06 UTC
Created attachment 860722 [details]
File: program.log

Comment 8 Jeff Bastian 2014-02-07 22:09:08 UTC
Created attachment 860723 [details]
File: storage.log

Comment 9 Jeff Bastian 2014-02-07 22:09:10 UTC
Created attachment 860724 [details]
File: syslog

Comment 10 Jeff Bastian 2014-02-07 22:09:11 UTC
Created attachment 860725 [details]
File: ifcfg.log

Comment 11 Jeff Bastian 2014-02-07 22:09:13 UTC
Created attachment 860726 [details]
File: packaging.log

Comment 13 Chris Lumens 2014-02-12 20:12:58 UTC
70368ec3b239b9a0583faaa81b1161d7c5d46d4f on master.

Comment 16 David Lehman 2014-02-25 23:01:48 UTC
*** Bug 1069693 has been marked as a duplicate of this bug. ***

Comment 17 IBM Bug Proxy 2014-02-25 23:06:09 UTC
Created attachment 867673 [details]
anaconda.log

default comment by bridge

Comment 18 IBM Bug Proxy 2014-02-25 23:06:12 UTC
Created attachment 867674 [details]
program log

default comment by bridge

Comment 19 IBM Bug Proxy 2014-02-25 23:06:14 UTC
Created attachment 867675 [details]
storage log

default comment by bridge

Comment 20 IBM Bug Proxy 2014-02-25 23:06:21 UTC
Created attachment 867676 [details]
anaconda-tb

default comment by bridge

Comment 24 Jeremy Eder 2014-02-26 20:06:15 UTC
Another user experienced a similar problem:

PXE install of 20140220 tree, added vnc nomodeset ip=eno1:dhcp to cmdline...Installer aborted when I clicked "update" after renaming the default VG for the / partition.  The name I changed it to was gear-overlay.

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=/distrotrees/65899/initrd method=http://download.eng.rdu.redhat.com/rel-eng/RHEL-7.0-20140220.2/compose/Server/x86_64/os/ repo=http://download.eng.rdu.redhat.com/rel-eng/RHEL-7.0-20140220.2/compose/Server/x86_64/os/ vnc nomodeset ip=eno1:dhcp BOOT_IMAGE=/distrotrees/65899/kernel 
hashmarkername: anaconda
kernel:         3.10.0-89.el7.x86_64
package:        anaconda-19.31.60-1
product:        Red Hat Enterprise Linux
reason:         TypeError: argument iter: Expected Gtk.TreeIter, but got int
release:        Red Hat Enterprise Linux Server release 7.0 Beta (Maipo)
release_type:   pre-release
version:        7.0

Comment 26 Chris Lumens 2014-02-27 14:39:30 UTC
Different traceback, different bug report.

Comment 28 Jan Stodola 2014-03-04 09:47:54 UTC
Retested with anaconda-19.31.64-1.el7 using both Btrfs and LVM partitioning, it was possible to change the Btrfs volume size to a fixed value as well as to change the name of LVM volume group.

Moving to VERIFIED.

Comment 29 David Shea 2014-03-06 14:38:56 UTC
*** Bug 1073414 has been marked as a duplicate of this bug. ***

Comment 30 IBM Bug Proxy 2014-03-13 13:22:30 UTC
------- Comment From thorsten.diehl@de.ibm.com 2014-03-13 13:18 EDT-------
Successfully verified on snapshot 10. Works also with various weird and mixed volume groups an several DASDs.  Closed!

Comment 31 Ludek Smid 2014-06-13 09:38:31 UTC
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Comment 33 IBM Bug Proxy 2019-04-08 14:34:55 UTC
------- Comment From hannsj_uhl@de.ibm.com 2019-04-08 10:18 EDT-------
.


Note You need to log in before you can comment on or make changes to this bug.