Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1062704 - nm-online in NetworkManager-wait-online.service not waiting for complete IP address assignment
Summary: nm-online in NetworkManager-wait-online.service not waiting for complete IP a...
Keywords:
Status: CLOSED DUPLICATE of bug 1030583
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: NetworkManager
Version: 7.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Rashid Khan
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-07 18:30 UTC by Kay Williams
Modified: 2014-04-08 14:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-04-08 14:11:17 UTC


Attachments (Terms of Use)
/var/log/messages showing Network Manager Wait Online returning too soon (deleted)
2014-02-07 18:30 UTC, Kay Williams
no flags Details

Description Kay Williams 2014-02-07 18:30:51 UTC
Created attachment 860632 [details]
/var/log/messages showing Network Manager Wait Online returning too soon

Description of problem:
On some systems, the nm-online utility returns success before the network is completely configured.

Version-Release number of selected component (if applicable):
NetworkManager-0.9.9.0-25.git20131108.el7.x86_64


How reproducible:
Depends on the system. In our testing using virtual machines, nm-online works as expected (e.g. does not return success until after stage 5 (IPv4 Commit). On at least one physical system, it reports success after stage 2 (Device Configure).


Steps to Reproduce:
1. sytemctl enable NetworkManager-wait-online.service
2. reboot
3. check /var/log/messages for ordering of "Started Network Manager Wait Online" message in relation to Network Manager "Activation ..." messages.
4. See attached (scrubbed) /var/log/messages file as an example


Additional info:
See related bug 837793 in Fedora 17 that was closed wontfix for lack of activity.

Comment 2 Jirka Klimes 2014-02-11 16:07:22 UTC
Would you try again with latest RHEL7 version?
There were fixes for the issue in NetworkManager-0.9.9.0-28.git20131212.

core: delay startup complete for initial carrier (rh #1030583)

Comment 3 Kay Williams 2014-02-11 17:53:22 UTC
Hello - The latest version I see either in Subscription Manager or from ftp.redhat.com is NetworkManager-0.9.9.0-25.git20131108. Am I missing something?

Comment 4 RHEL Product and Program Management 2014-03-22 06:04:48 UTC
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Comment 5 Thomas Haller 2014-04-08 14:11:17 UTC
This looks very much like the issue fixed by upstream commit http://cgit.freedesktop.org/NetworkManager/NetworkManager/commit/?id=61463ed2ab6ce61f8640bb4f871697a29f3a0639

and it should be long fixed.


closing this bug as duplicate of bug 1030583 (rhel-7).
The same bug in F20 is bug 1034921.

*** This bug has been marked as a duplicate of bug 1030583 ***


Note You need to log in before you can comment on or make changes to this bug.