Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1062612 - [RHSC] - User should not be able to run rebalance or remove-brick in 3.2 cluster
Summary: [RHSC] - User should not be able to run rebalance or remove-brick in 3.2 cluster
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc
Version: 2.1
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: RHGS 3.1.0
Assignee: Kanagaraj
QA Contact: RamaKasturi
URL:
Whiteboard:
Depends On: 1164798 1200294
Blocks: 1035040 1202842
TreeView+ depends on / blocked
 
Reported: 2014-02-07 13:27 UTC by RamaKasturi
Modified: 2016-04-18 10:06 UTC (History)
12 users (show)

Fixed In Version: rhsc-3.1.0-57
Doc Type: Bug Fix
Doc Text:
Previously, when Red Hat Storage 2.1 Update 2 nodes were added to 3.2 cluster, users were allowed to perform rebalance and remove-brick operations which are not supported in 3.2 cluster. As a consequence, further volume operations were not allowed as the volume is locked. With this fix, an error message is displayed when users execute the rebalance and remove brick commands in version 3.2 cluster.
Clone Of:
Environment:
Last Closed: 2015-07-29 05:25:30 UTC
Target Upstream Version:


Attachments (Terms of Use)
Attaching the rebalance screenshot for 3.2 cluster (deleted)
2015-05-27 11:15 UTC, RamaKasturi
no flags Details
Attaching remove brick screenshot for 3.2 cluster. (deleted)
2015-05-27 11:16 UTC, RamaKasturi
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:1494 normal SHIPPED_LIVE Red Hat Gluster Storage Console 3.1 Enhancement and bug fixes 2015-07-29 09:24:02 UTC
oVirt gerrit 39673 None None None Never

Description RamaKasturi 2014-02-07 13:27:01 UTC
Description of problem:
when added a 2.1 u2 node to 3.2 cluster user is able to perform rebalance and remove-brick.

Version-Release number of selected component (if applicable):
rhsc-2.1.2-0.36.el6rhs.noarch

How reproducible:
Always

Steps to Reproduce:
1. Create a 3.2 cluster
2. Add a 2.1 U2 node in the cluster
3. Create a volume on that.
4. 

Actual results:
user is able to perfom rebalance and remove brick.

Expected results:
1) Rebalance and remove brick buttons should be disabled as they are not supported in 3.2 cluster.

2)Remove brick should directly remove the brick, with out prompting the user for data migration.


Additional info:

Comment 1 Dusmant 2014-02-10 09:22:30 UTC
We should document this -- If a host is added to 3.2 cluster, we assume it supports only 3.2 features even though host is capable of doing more.

Comment 2 Shalaka 2014-02-11 12:00:35 UTC
Please add doc text for this known issue.

Comment 3 Shalaka 2014-02-12 10:12:58 UTC
Please review the edited doc text and sign off.

Comment 4 Kanagaraj 2014-02-12 10:15:33 UTC
doc_text looks good.

Comment 6 RamaKasturi 2015-05-22 07:17:13 UTC
Please provide the fixed in version.

Comment 7 RamaKasturi 2015-05-27 11:12:15 UTC
Added a 3.1 node to 3.2 cluster and tried performing rebalance and remove brick.

When user tries to perform a rebalance in 3.2 cluster it displays an error saying " Error while executing action: cannot rebalance Gluster Volume. Gluster task management is not supported in compatibility version 3.2."

When user tries to perform a remove brick in 3.2 cluster it displays an error saying "Error while executing action: cannot start removing Brick(s). Gluster task management is not supported in compatibility version 3.2."

Comment 8 RamaKasturi 2015-05-27 11:15:59 UTC
Created attachment 1030491 [details]
Attaching the rebalance screenshot for 3.2 cluster

Comment 9 RamaKasturi 2015-05-27 11:16:32 UTC
Created attachment 1030492 [details]
Attaching remove brick screenshot for 3.2 cluster.

Comment 10 Divya 2015-07-26 07:00:17 UTC
Kanagaraj,

Please review and sign-off the edited doc text.

Comment 11 Kanagaraj 2015-07-27 10:11:47 UTC
please change "execute the rebalance and remove brick commands in version 3.2 cluster" to "perform the rebalance and remove brick operations in version 3.2 cluster"

Rest looks good

Comment 13 errata-xmlrpc 2015-07-29 05:25:30 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-1494.html


Note You need to log in before you can comment on or make changes to this bug.