Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1062611 - add-user: '@' is not among non-alphanumeric characters during user name validatin
Summary: add-user: '@' is not among non-alphanumeric characters during user name valid...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Scripts and Commands
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: DR6
: EAP 6.3.0
Assignee: Darran Lofthouse
QA Contact: Petr Kremensky
Russell Dickenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-07 13:25 UTC by Petr Kremensky
Modified: 2014-06-28 15:27 UTC (History)
5 users (show)

Doc Type: Bug Fix
Doc Text:
The `add-user` utility in previous versions of JBoss EAP 6 would display a misleading error message when an invalid username was entered. The messaged stated that a username must be alphanumeric, when in fact the utility had been modified to accept a subset of special symbols in usernames. The error message has been reconstructed to contain the list of acceptable symbols and users now see a more accurate error message when an invalid username is entered.
Clone Of:
Environment:
Last Closed: 2014-06-28 15:27:05 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
JBoss Issue Tracker WFLY-3133 Major Resolved Misleading error message for add-user username requirements. 2017-07-20 19:05:21 UTC

Description Petr Kremensky 2014-02-07 13:25:55 UTC
Description of problem:
 User name should contain only alphanumeric characters, but I am able use '@' in user's name.

Version-Release number of selected component (if applicable):
 EAP 6.2.0

How reproducible:
 Always

Steps to Reproduce:
 1. Navigate into $EAP_HOME/bin directory 
 2. run: bin]$ ./add-user.sh aaa@aaa asdasd@2

Actual results:
Added user 'aaa@aaa' to file '/home/pkremens/devel/jboss-eap-6.2/standalone/configuration/mgmt-users.properties'
Added user 'aaa@aaa' to file '/home/pkremens/devel/jboss-eap-6.2/domain/configuration/mgmt-users.properties'

Expected results:
 * Error * 
JBAS015239: Only alpha/numeric usernames accepted.

Additional info:
 EAP is not complaining about aaa@aaa user

Comment 1 Permaine Cheung 2014-02-07 15:06:42 UTC
Darran, can you please look into this or reassign if you're not the right person for this?

Comment 2 Darran Lofthouse 2014-03-18 18:22:26 UTC
After further investigation this is intended behaviour, a small subset of symbols are now accepted in the username.  I am updating the error message on an invalid username to reflect this.

Comment 5 Petr Kremensky 2014-03-31 05:52:15 UTC
Verified on EAP 6.3.0.DR6.

Comment 6 Scott Mumford 2014-04-24 01:17:38 UTC
Refactored release notes text and marked for inclusion in documentation.

Comment 7 sgilda 2014-05-12 20:07:03 UTC
Changed <literal></literal> tags in Doc Text to ticks (`) to fix Bug 1096865


Note You need to log in before you can comment on or make changes to this bug.