Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1062487 - flite-2.1.0 is available
Summary: flite-2.1.0 is available
Keywords:
Status: NEW
Alias: None
Product: Fedora
Classification: Fedora
Component: flite
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Peter Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-07 03:27 UTC by Christopher Meng
Modified: 2019-03-22 12:03 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed:


Attachments (Terms of Use)

Description Christopher Meng 2014-02-07 03:27:57 UTC
This package hasn't been updated to 1.4, can you do an update for f20+?

I have one package depends on this.

Thanks.

Comment 1 Jaroslav Reznik 2015-03-03 15:27:34 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 22 development cycle.
Changing version to '22'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora22

Comment 2 Trever Adams 2015-07-14 21:42:33 UTC
Is there a possibility of seeing flite 2.0 in f22 or f23? I have packages (outside of Fedora) that need this.

Comment 3 Peter Robinson 2015-07-14 21:48:27 UTC
Maybe, got a link to the flite2 site, and maybe your spec file? Is it abi/api compatible?

Comment 4 Trever Adams 2015-07-14 21:50:39 UTC
http://festvox.org/flite/packed/flite-2.0/ is where I found it. I don't know if it is abi/api compatible. I don't have a spec file for it as FreeSWITCH (the package I need it for) until recently would download, compile and use its own copy if the system didn't have it. They are doing the right thing by moving more and more of their dependencies to use unmodified system versions. The problem is, Fedora lacks many of these.

Comment 5 Adri Verhoef 2016-01-18 11:41:26 UTC
I was reading at https://bugzilla.redhat.com/show_bug.cgi?id=1190810 that prelink doesn't get installed by default anymore (I'm running Fedora 23).
Now when 'flite' is updated to 1.3-25, this message appears during 'dnf update':

Downloading Packages:
(1/2): libetonyek-0.1.6-1.fc23.x86_64.rpm
(2/2): flite-1.3-23.fc22_1.3-25.fc23.x86_64.drpm
/usr/sbin/prelink: No such file or directory
prelink not installed, cannot undo prelinking
flite-1.3-25.fc23.x86_64: Delta RPM rebuild failed
flite-1.3-25.fc23.x86_64.rpm

Does the 'flite' package need a check to see whether prelink is installed or not?

Comment 6 Peter Robinson 2016-01-18 12:23:27 UTC
(In reply to Adri Verhoef from comment #5)
> I was reading at https://bugzilla.redhat.com/show_bug.cgi?id=1190810 that
> prelink doesn't get installed by default anymore (I'm running Fedora 23).
> Now when 'flite' is updated to 1.3-25, this message appears during 'dnf
> update':

Unrelated to this bug

> Does the 'flite' package need a check to see whether prelink is installed or
> not?

flite doesn't depend on prelink at all so I suspect it's actually an unrelated package

Comment 7 Dominik 'Rathann' Mierzejewski 2016-07-10 22:32:36 UTC
flite is also required by flite support in FFmpeg, but Fedora's 1.3 is not detected (missing some libraries). I'll check which version is required and post back.

Comment 8 Jan Kurik 2016-07-26 04:54:09 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 25 development cycle.
Changing version to '25'.

Comment 9 barsnick 2016-12-09 16:00:30 UTC
(In reply to Dominik 'Rathann' Mierzejewski from comment #7)
> flite is also required by flite support in FFmpeg, but Fedora's 1.3 is not
> detected (missing some libraries). I'll check which version is required and
> post back.

ffmpeg relies on flite-1.4. I have been using a private patch to allow flite-1.3, I will submit that to ffmpeg-devel.

Nevertheless, flite-1.4 seems API-compatible, so Fedora should provide it.

Comment 10 solanum 2017-04-23 05:00:23 UTC
I need 1.4 too. 
Is anyone aware that cmu still maintains it via a different site and it is at version 2.0?
http://www.festvox.org/

Comment 11 Dominik 'Rathann' Mierzejewski 2017-07-24 21:16:49 UTC
Bumping to rawhide, where it's still not updated. Please update to at least 1.4 (or 2.0.0) or I'll do it myself if there's no response in two weeks.

Comment 12 Jan Kurik 2017-08-15 07:11:01 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 27 development cycle.
Changing version to '27'.

Comment 13 Zbigniew Jędrzejewski-Szmek 2018-01-06 12:18:15 UTC
Dominik, what about that update? ;)

Comment 14 Dominik 'Rathann' Mierzejewski 2018-01-06 15:06:42 UTC
Sorry, I (obviously) didn't have time for that. Please go ahead if you want. I still have other higher priority stuff to attend to.

Comment 15 Ben Cotton 2018-11-27 17:33:54 UTC
This message is a reminder that Fedora 27 is nearing its end of life.
On 2018-Nov-30  Fedora will stop maintaining and issuing updates for
Fedora 27. It is Fedora's policy to close all bug reports from releases
that are no longer maintained. At that time this bug will be closed as
EOL if it remains open with a Fedora  'version' of '27'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 27 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

Comment 16 Trever Adams 2018-11-27 22:13:56 UTC
This is still an issue for me. Also, I am at F29 now, not F27. Is it possible to version bump this.

Comment 17 Brandon Amaro 2019-03-22 00:02:27 UTC
This package really, really needs to be updated. Version 2.1.0 was released in 2017.

http://www.festvox.org/


Note You need to log in before you can comment on or make changes to this bug.