Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1062483 - udpxy-1.0.23.9 is available
Summary: udpxy-1.0.23.9 is available
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: udpxy
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: nucleo
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-07 03:10 UTC by Christopher Meng
Modified: 2014-07-22 03:31 UTC (History)
1 user (show)

Fixed In Version: udpxy-1.0.23-1.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-22 03:31:49 UTC


Attachments (Terms of Use)

Description Christopher Meng 2014-02-07 03:10:18 UTC
1. Bug 850349 said that new systemd macros should be used, however they are obsoleted again:

https://fedoraproject.org/wiki/Packaging:ScriptletSnippets#Systemd

2. This package has new version:

http://www.udpxy.com/download-en.html

3. URL should be:

URL:  http://www.udpxy.com

4. Remove:

%defattr(-,root,root,-)

rm -rf %{buildroot}

5 Advice:

sed -i "s|INSTALLROOT := /usr/local|INSTALLROOT := %{buildroot}/usr|g" Makefile
sed -i 's|ln -s $(INSTALLROOT)/bin/$(EXEC)|ln -s $(EXEC)|g' Makefile


This should be moved to %prep.

Thanks!

Comment 1 nucleo 2014-02-07 03:33:42 UTC
(In reply to Christopher Meng from comment #0)
> 1. Bug 850349 said that new systemd macros should be used, however they are
> obsoleted again:
> 
> https://fedoraproject.org/wiki/Packaging:ScriptletSnippets#Systemd

What wrong with macros?
 

> 5 Advice:
> 
> sed -i "s|INSTALLROOT := /usr/local|INSTALLROOT := %{buildroot}/usr|g"
> Makefile
> sed -i 's|ln -s $(INSTALLROOT)/bin/$(EXEC)|ln -s $(EXEC)|g' Makefile
> 
> 
> This should be moved to %prep.

It in %install for a reason.

rpm-buildroot-usage:
$RPM_BUILD_ROOT should not be touched during %build or %prep stage, as it may
break short circuit builds.

Comment 2 Christopher Meng 2014-02-07 03:51:32 UTC
(In reply to nucleo from comment #1)
> (In reply to Christopher Meng from comment #0)
> > 1. Bug 850349 said that new systemd macros should be used, however they are
> > obsoleted again:
> > 
> > https://fedoraproject.org/wiki/Packaging:ScriptletSnippets#Systemd
> 
> What wrong with macros?

Ooops, unclear.

These:

BuildRequires:  systemd-units

Requires(post): systemd-units
Requires(preun): systemd-units
Requires(postun): systemd-units

Should be:

BuildRequires:     systemd
Requires(post):    systemd
Requires(preun):   systemd
Requires(postun):  systemd

> rpm-buildroot-usage:
> $RPM_BUILD_ROOT should not be touched during %build or %prep stage, as it may
> break short circuit builds.

Then I think the makefile is a crap which should be enhanced. Alright.

Comment 3 Christopher Meng 2014-06-06 02:39:29 UTC
What's been happening?

Comment 4 Fedora Update System 2014-06-29 07:32:06 UTC
udpxy-1.0.23-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/udpxy-1.0.23-1.fc20

Comment 5 Fedora Update System 2014-06-30 10:33:08 UTC
Package udpxy-1.0.23-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing udpxy-1.0.23-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-7897/udpxy-1.0.23-1.fc20
then log in and leave karma (feedback).

Comment 6 Fedora Update System 2014-07-22 03:31:49 UTC
udpxy-1.0.23-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.