Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1062479 - [abrt] yum-utils: __init__.py:2160:doLock:AssertionError
Summary: [abrt] yum-utils: __init__.py:2160:doLock:AssertionError
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: rawhide
Hardware: x86_64
OS: Unspecified
urgent
high
Target Milestone: ---
Assignee: Packaging Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:dd295f2fa9e45974f1f041e38a6...
: 1061643 1065768 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-07 02:51 UTC by Adam Williamson
Modified: 2014-05-28 02:53 UTC (History)
10 users (show)

Fixed In Version: yum-3.4.3-137.fc19
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-28 18:30:02 UTC


Attachments (Terms of Use)
File: backtrace (deleted)
2014-02-07 02:51 UTC, Adam Williamson
no flags Details
File: environ (deleted)
2014-02-07 02:51 UTC, Adam Williamson
no flags Details

Description Adam Williamson 2014-02-07 02:51:28 UTC
Description of problem:
Tried to use debuginfo-install on current Rawhide.

Version-Release number of selected component:
yum-utils-1.1.31-21.fc21

Additional info:
reporter:       libreport-2.1.12
cmdline:        /usr/bin/python /usr/bin/debuginfo-install gjs
dso_list:       yum-3.4.3-134.fc21.noarch
executable:     /usr/bin/debuginfo-install
kernel:         3.14.0-0.rc1.git0.3.fc21.x86_64
runlevel:       N 5
type:           Python
uid:            0

Truncated backtrace:
__init__.py:2160:doLock:AssertionError

Traceback (most recent call last):
  File "/usr/bin/debuginfo-install", line 200, in <module>
    util = DebugInfoInstall()
  File "/usr/bin/debuginfo-install", line 57, in __init__
    self.main()
  File "/usr/bin/debuginfo-install", line 107, in main
    self.doUtilYumSetup()
  File "/usr/share/yum-cli/utils.py", line 352, in doUtilYumSetup
    self.waitForLock()
  File "/usr/share/yum-cli/cli.py", line 518, in waitForLock
    self.doLock()
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 2160, in doLock
    assert ret == 1
AssertionError

Local variables in innermost frame:
mypid: '14107'
self: <__main__.DebugInfoInstall object at 0x28c1cd0>
ret: 0
oldpid: 14107
lockfile: '/var/run/yum.pid'
root: '/'

Comment 1 Adam Williamson 2014-02-07 02:51:32 UTC
Created attachment 860369 [details]
File: backtrace

Comment 2 Adam Williamson 2014-02-07 02:51:33 UTC
Created attachment 860370 [details]
File: environ

Comment 3 Igor Gnatenko 2014-02-07 19:20:23 UTC
Another user experienced a similar problem:

$ sudo debuginfo-install --enablerepo koji geoclue2

reporter:       libreport-2.1.12
cmdline:        /usr/bin/python /bin/debuginfo-install --enablerepo koji geoclue2
dso_list:       yum-3.4.3-134.fc21.noarch
executable:     /bin/debuginfo-install
kernel:         3.14.0-0.rc1.git0.2.fc21.x86_64
package:        yum-utils-1.1.31-21.fc21
reason:         __init__.py:2160:doLock:AssertionError
runlevel:       N 5
type:           Python
uid:            0

Comment 4 Christian Stadelmann 2014-02-16 14:13:21 UTC
This is a bug in yum, not in yum-utils:

Downgrading yum-utils-1.1.31-20.fc20 to yum-1.1.31-18.fc20 did not work.

Downgrading yum-3.4.3-135.fc20 to yum-3.4.3-132.fc20 works. This could be used as a workaround until the bug is fixed.

Comment 5 Valentina Mukhamedzhanova 2014-02-17 10:02:04 UTC
*** Bug 1065768 has been marked as a duplicate of this bug. ***

Comment 7 Fedora Update System 2014-02-17 16:13:47 UTC
yum-3.4.3-137.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/FEDORA-2014-2482/yum-3.4.3-137.fc20

Comment 8 Fedora Update System 2014-02-17 16:31:55 UTC
yum-3.4.3-137.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/FEDORA-2014-2541/yum-3.4.3-137.fc19

Comment 9 Fedora Update System 2014-02-18 13:36:58 UTC
Package yum-3.4.3-137.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing yum-3.4.3-137.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-2541/yum-3.4.3-137.fc19
then log in and leave karma (feedback).

Comment 10 Fedora Update System 2014-02-28 18:30:02 UTC
yum-3.4.3-137.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Valentina Mukhamedzhanova 2014-03-11 10:39:31 UTC
*** Bug 1061643 has been marked as a duplicate of this bug. ***

Comment 12 Fedora Update System 2014-05-28 02:53:07 UTC
yum-3.4.3-137.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.