Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1062380 - The --pid-file option is passed to vpnc incorrectly
Summary: The --pid-file option is passed to vpnc incorrectly
Keywords:
Status: CLOSED DUPLICATE of bug 1062555
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager-vpnc
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Dan Williams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-06 18:44 UTC by Nalin Dahyabhai
Modified: 2014-02-11 11:09 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-11 11:09:08 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 723804 None None None Never

Description Nalin Dahyabhai 2014-02-06 18:44:48 UTC
Description of problem:
NetworkManager-vpnc passes the --pid-file option and its value as a single element of vpnc's argv[], causing the option to not be recognized by vpnc's option parsing logic, which expects them to be two consecutive arguments.

Version-Release number of selected component (if applicable):
NetworkManager-vpnc-0.9.9.0-2.git20140131.fc21.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Attempt to bring up a vpnc connection.

Actual results:
from my /var/log/messages:
Feb  6 10:46:10 pillbox NetworkManager[824]: /usr/sbin/vpnc: unknown option --pid-file /var/run/NetworkManager/nm-vpnc-6143a9d5-bb40-44af-801f-3cfae2683b83.pid

Comment 1 Jirka Klimes 2014-02-11 11:09:08 UTC
Nalin, thanks for reporting.
The bug has been fixed, please install NetworkManager-vpnc-0.9.9.0-3.git20140131.fc21.

*** This bug has been marked as a duplicate of bug 1062555 ***


Note You need to log in before you can comment on or make changes to this bug.