Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1062316 - leftover LVs and device mapper entries after 'removal' of virtual sized LV in a cluster
Summary: leftover LVs and device mapper entries after 'removal' of virtual sized LV in...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: lvm2-cluster
Version: 5.10
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: LVM and device-mapper development team
QA Contact: Cluster QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-06 16:15 UTC by Nenad Peric
Modified: 2019-03-13 15:30 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-02 13:06:33 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Nenad Peric 2014-02-06 16:15:05 UTC
Description of problem:

When a virtual-sized LV is created in a cluster, it does not get removed completely, which causes either an extensive manual cleanup or an eventual lvm lockup. 


Version-Release number of selected component (if applicable):

lvm2-2.02.88-12.el5
lvm2-cluster-2.02.88-9.el5_10.2
device-mapper-1.02.67-2.el5


How reproducible:
Everytime

Steps to Reproduce:
create a clustered VG vg_shared

 Run this script twice:

#!/bin/bash

vg_name="vg_shared"
dev_name="worker-001" # get this from ENV or param

if [[ -e /dev/$vg_name/$dev_name ]]; then
	echo "Removing already existing device $vg_name/$dev_name"
	lvremove -ff "$vg_name/$dev_name"
fi
echo "Creating device $vg_name/$dev_name"
lvcreate -L 100G -V 1T -n $dev_name $vg_name


Actual results:

On the second run, it cannot remove the LV properly, but removes the entries on the node it was run on, the rest of the nodes keep the LV (or remove it but keep all the device mapper data). 
the internal _vorigin LV is kept as well on all nodes after LV removal.  

Expected results:

Clean removal of LV on all nodes, both in device mapper and in lvm. 

Additional info:

Comment 1 RHEL Product and Program Management 2014-03-07 12:42:54 UTC
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.

Comment 2 RHEL Product and Program Management 2014-06-02 13:06:33 UTC
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).


Note You need to log in before you can comment on or make changes to this bug.