Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1062274 - IPC::Run3::run3($command, \undef) clobbers STDIN
Summary: IPC::Run3::run3($command, \undef) clobbers STDIN
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: perl-IPC-Run3
Version: 7.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: perl-maint-list
QA Contact: BaseOS QE - Apps
URL:
Whiteboard:
Depends On:
Blocks: 1305230
TreeView+ depends on / blocked
 
Reported: 2014-02-06 14:54 UTC by Petr Pisar
Modified: 2017-07-07 06:37 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1062267
Environment:
Last Closed: 2017-07-07 06:37:06 UTC


Attachments (Terms of Use)
Proposed fix (deleted)
2014-02-06 14:54 UTC, Petr Pisar
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
CPAN 52317 None None None Never

Description Petr Pisar 2014-02-06 14:54:53 UTC
Created attachment 860209 [details]
Proposed fix

+++ This bug was initially created as a clone of Bug #1062267 +++

If IPC::Run3::run3() is invoked with \undef for command's standard input, it will clobber STDIN, so STDIN is unusable after return from run3():

Reproducer:

$ printf '1\n2\n'| perl -MIPC::Run3 -e 'while (<>) { print; run3([q{true}], \undef) }' 
1

This should print:

1
2

But it stops after first loop.

Observed in perl-IPC-Run3-0.046-3.fc20.noarch, F20.

Reported to upstream, patch is there.

-----

RHEL-7 is affected (perl-IPC-Run3-0.045-6.el7.noarch).

Comment 5 Petr Pisar 2017-07-07 06:37:06 UTC
The patch does not fix it. It seems to be an intrinsic limitation for the perl interpreter.


Note You need to log in before you can comment on or make changes to this bug.