Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1062256 - mount hangs, when all the bricks in replica group go down while writes are in progress
Summary: mount hangs, when all the bricks in replica group go down while writes are in...
Keywords:
Status: CLOSED DUPLICATE of bug 1061580
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterfs
Version: 2.1
Hardware: x86_64
OS: Linux
high
urgent
Target Milestone: ---
: ---
Assignee: Pranith Kumar K
QA Contact: SATHEESARAN
URL:
Whiteboard:
Depends On: 1061580 1063190
Blocks: 1035040
TreeView+ depends on / blocked
 
Reported: 2014-02-06 14:24 UTC by Vivek Agarwal
Modified: 2016-02-18 00:03 UTC (History)
12 users (show)

Fixed In Version: glusterfs-3.6.0.5-1
Doc Type: Known Issue
Doc Text:
When all the bricks in replica group go down while writes are in progress on that replica group, the mount may hang. Workaround: Kill the mount process, perform a lazy unmount of the existing mount and remount.
Clone Of: 1061580
Environment:
Last Closed: 2014-05-30 06:26:25 UTC


Attachments (Terms of Use)

Comment 2 Shalaka 2014-02-10 09:15:41 UTC
Please add doc text for this known issue.

Comment 3 SATHEESARAN 2014-02-11 09:31:52 UTC
Modifying the bug summary, as this no longer relevant to server-quorum only, as per https://bugzilla.redhat.com/show_bug.cgi?id=1061580#c25

Comment 4 Shalaka 2014-02-11 09:36:23 UTC
Please review the doc text and sign off.

Comment 5 Pranith Kumar K 2014-02-11 09:59:17 UTC
When all the bricks in replica group go down while writes are in progress *on that replica group*, the mount may hang. Workaround: Kill the mount process and remount.

Added some text in '*' just add that part and we are good to go.

Comment 6 Shalaka 2014-02-11 11:30:23 UTC
Updated the doc text as suggested by Satheesaran.

Comment 8 SATHEESARAN 2014-05-29 17:32:20 UTC
This bug was initially cloned for doc effort to add this bug under known issue.
The exact bug was actually handled with this BZ, https://bugzilla.redhat.com/show_bug.cgi?id=1061580

I would prefer marking this bug as duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1061580

Comment 9 SATHEESARAN 2014-05-29 17:34:14 UTC
Raising need-info for any other thoughts on comment8

Comment 10 Vivek Agarwal 2014-05-30 05:54:08 UTC
This is a duplicate of the https://bugzilla.redhat.com/show_bug.cgi?id=1061580, seems fine with me

Comment 11 SATHEESARAN 2014-05-30 06:26:25 UTC
(In reply to Vivek Agarwal from comment #10)
> This is a duplicate of the
> https://bugzilla.redhat.com/show_bug.cgi?id=1061580, seems fine with me

Thanks, marking this bug as the duplicate

*** This bug has been marked as a duplicate of bug 1061580 ***


Note You need to log in before you can comment on or make changes to this bug.