Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1062249 - Change in 'Install Disk' behaviour of new rhev-h installation script.
Summary: Change in 'Install Disk' behaviour of new rhev-h installation script.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node
Version: unspecified
Hardware: x86_64
OS: Linux
urgent
urgent
Target Milestone: ---
: 3.5.0
Assignee: Fabian Deutsch
QA Contact: Virtualization Bugs
URL:
Whiteboard: node
: 1052838 (view as bug list)
Depends On:
Blocks: 1123329 rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2014-02-06 14:06 UTC by Prasad Mukhedkar
Modified: 2018-12-04 17:24 UTC (History)
18 users (show)

Fixed In Version: ovirt-node-3.0.1-18.el6_5.3
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-11 20:51:43 UTC
oVirt Team: Node


Attachments (Terms of Use)
Boot disk screen of older RHEV-H (deleted)
2014-02-06 14:07 UTC, Prasad Mukhedkar
no flags Details
Install Disk selection screen of older version RHEV-H (deleted)
2014-02-06 14:08 UTC, Prasad Mukhedkar
no flags Details
Boot Disk selection screen of RHEV-H 6.5 (deleted)
2014-02-06 14:09 UTC, Prasad Mukhedkar
no flags Details
Install Disk selection screen of RHEV-H 6.5 (deleted)
2014-02-06 14:10 UTC, Prasad Mukhedkar
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:0160 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update 2015-02-12 01:34:52 UTC

Description Prasad Mukhedkar 2014-02-06 14:06:06 UTC
Description of problem:

We have observed a change in disk configuration menu of new RHEVH installation script, In earlier version, The disk which is selected in 'boot disk' screen is also by default gets selected in 'installation disk' screen and gives user option to select addition or different disk for hypervisor installation if  required. 

But in the new version at the installation disk menu, First disk visible to hypervisor gets selected as 'Install DISK' automatically rather than the disk which was selected as boot disk in previous screen (Boot Disk Menu)

This change is no where documented and seen that customers/users who are used with old menu styling simply ignore the selection of first disk (which could be a lun visible to hypervisor and used to build rhev storage domain) and proceed with the installation. This can cause production down unrecoverable issue.

One of my premium customer, During the re-installation of a hypervisor did not notice that the first disk visible to his hypervisor got selected as installtion disk which was actually a LUN containing large number of virtual machine disks rather then the local disk. As customer was familiar with older RHEV-H installation interface. proceed the installation without checking which disk is actually selected as install disk and lost all the vms disk data. 

See the attached screenshot to get better idea of the issue. 

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.5-20140112.0.el6ev

How reproducible:
always 

Steps to Reproduce:
 Start the hypervisor installation. Select second disk visible to hypervisor as 'boot disk'. In next screen, that is 'installation disk' the first disk will get automatically selected as 'install disk' 


Actual results:

First disk visible to hypervisor gets selected as install disk automatically.

Expected results:

Install disk should remain the same as boot disk and gives user option to select another disk for rhevh installation if and only required.

Additional info:

Comment 1 Prasad Mukhedkar 2014-02-06 14:07:24 UTC
Created attachment 860186 [details]
Boot disk screen of older RHEV-H

Comment 2 Prasad Mukhedkar 2014-02-06 14:08:29 UTC
Created attachment 860188 [details]
Install Disk selection screen of older version RHEV-H

Comment 3 Prasad Mukhedkar 2014-02-06 14:09:51 UTC
Created attachment 860189 [details]
Boot Disk selection screen of  RHEV-H 6.5

Comment 4 Prasad Mukhedkar 2014-02-06 14:10:21 UTC
Created attachment 860190 [details]
Install Disk selection screen of  RHEV-H 6.5

Comment 7 Fabian Deutsch 2014-02-09 23:12:07 UTC
Hey,

I was able to reproduce this bug and it's also possible to go back to the behavior of the previous installer TUI.

Let me note that the erratum for the RHEV 6.5 for RHEV 3.3 release contained a section informing the user that there is now a new TUI for the setup and installer.

Comment 14 Fabian Deutsch 2014-02-13 10:56:52 UTC
*** Bug 1052838 has been marked as a duplicate of this bug. ***

Comment 15 Fabian Deutsch 2014-02-13 14:58:31 UTC
Ouyang, could you open an RFE for your comment 11?

Comment 20 Yaning Wang 2014-12-10 08:09:26 UTC
Tested on:

RHEV-H 6.6-20141119.0.el6ev
ovirt-node-3.1.0-0.27.20141119git24e087e.el6.noarch


Steps to Reproduce:

Start the hypervisor installation. Select second disk visible to hypervisor as 'boot disk'. 


Actual results:

second disk visible to hypervisor gets selected as install disk

Expected results:

Install disk remain the same as boot disk

Comment 22 errata-xmlrpc 2015-02-11 20:51:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0160.html


Note You need to log in before you can comment on or make changes to this bug.