Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1062134 - Installation not start with less of 500Mb of Ram
Summary: Installation not start with less of 500Mb of Ram
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 20
Hardware: i386
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-06 09:36 UTC by MarcoBoretto
Modified: 2014-02-20 19:54 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-20 19:54:32 UTC


Attachments (Terms of Use)

Description MarcoBoretto 2014-02-06 09:36:40 UTC
Description of the problem:
Hello everybody, I've tryed to install Fedora 20 on an aged computer(Pentium III with 386MB of Ram). I've dowload some ditribution spin like LXDE and the network-install. Whit both spin, when i start the installation startup anaconda fail, due to shortage of RAM.

Version-Release number of selected component (if applicable):


How reproducible:
I think it could be seen with a virtual machine with less of 500Mb of Ram or an old computer.

Steps to Reproduce:
1. search a computer/Virtual Machine with less of 500Mb of 
2. boot from a distribution of Fedora 20 LXDE or network-install
3. If you use the LXDE the installation do not start, with the network install you get the error "not enough Ram press ok to restart" and then "Pane is Dead"

Actual results:
With some Hack i manage to install fedora 20!
Here the step:
1 Boot Fedora LXDE, when the environment is ready, open a shell
2 cd /sbin , su, vi anaconda
3 search the two line with: "if needed_ram > total_ram:" they are approximatly at 406 and 425
4 change the operator from > to < , for both line
5 close and save vi
6 cd /usr/bin
7 ./liveinst

The installation go fine!

Expected results: I'd like to use start Fedora installation even with less than 500Mb of Ram. 
This Threshold limit is not correct because i manage to perform the installation with less Ram. This Threshold could be set different for each spin. For example, LXDE and network-install need less ram than GNOME3.

Comment 1 David Shea 2014-02-20 19:54:32 UTC
The required amount of memory is not a hard limit: it may be possible in some situations to install with less RAM, but we are not going to support such cases.


Note You need to log in before you can comment on or make changes to this bug.