Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1061897 - Cannot install cifs-utils due to conflict with ipa-server-trust-ad samba4 dependancies
Summary: Cannot install cifs-utils due to conflict with ipa-server-trust-ad samba4 dep...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: doc-Identity_Management_Guide
Version: 6.5
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Deon Ballard
QA Contact: ecs-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-05 20:38 UTC by Steve Dainard
Modified: 2014-02-06 23:52 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-06 23:44:25 UTC


Attachments (Terms of Use)

Description Steve Dainard 2014-02-05 20:38:20 UTC
Description of problem:

Following this documentation: https://access.redhat.com/site/documentation/en-US/Red_Hat_Enterprise_Linux/6/html/Identity_Management_Guide/trust-diff-dns-domains.html in step #3 I cannot install the cifs-utils package due to samba3 dependancies.


Version-Release number of selected component (if applicable):


How reproducible: Always

Steps to Reproduce:
1. # yum install ipa-server "*ipa-server-trust-ad" samba4-winbind-clients bind-dyndb-ldap samba4-client
2. # yum install cifs-utils


Actual results:

Loaded plugins: product-id, security, subscription-manager
This system is receiving updates from Red Hat Subscription Management.
rhel-6-server-cf-tools-1-rpms                                 | 2.8 kB     00:00     
rhel-6-server-rhev-agent-rpms                                 | 3.1 kB     00:00     
rhel-6-server-rpms                                            | 3.7 kB     00:00     
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package cifs-utils.x86_64 0:4.8.1-19.el6 will be installed
--> Processing Dependency: libwbclient.so.0()(64bit) for package: cifs-utils-4.8.1-19.el6.x86_64
--> Running transaction check
---> Package samba-winbind-clients.x86_64 0:3.6.9-167.el6_5 will be installed
--> Processing Dependency: samba-winbind = 3.6.9-167.el6_5 for package: samba-winbind-clients-3.6.9-167.el6_5.x86_64
--> Running transaction check
---> Package samba-winbind.x86_64 0:3.6.9-167.el6_5 will be installed
--> Processing Dependency: samba-common = 3.6.9-167.el6_5 for package: samba-winbind-3.6.9-167.el6_5.x86_64
--> Running transaction check
---> Package samba-common.x86_64 0:3.6.9-167.el6_5 will be installed
--> Processing Conflict: samba4-common-4.0.0-60.el6_5.rc4.x86_64 conflicts samba-common < 3.9.9
--> Processing Conflict: samba4-winbind-4.0.0-60.el6_5.rc4.x86_64 conflicts samba-winbind < 3.9.9
--> Processing Conflict: samba4-winbind-clients-4.0.0-60.el6_5.rc4.x86_64 conflicts samba-winbind-clients < 3.9.9
--> Finished Dependency Resolution
Error: samba4-common conflicts with samba-common-3.6.9-167.el6_5.x86_64
Error: samba4-winbind-clients conflicts with samba-winbind-clients-3.6.9-167.el6_5.x86_64
Error: samba4-winbind conflicts with samba-winbind-3.6.9-167.el6_5.x86_64
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Expected results:

Either the cifs-utils package should install, or if it is not a required component of "Setting up Trust with IdM and Active Directory in Different DNS Domains" then it should be removed from the documentation.

Additional info:

# rpm -qa | grep ipa
libipa_hbac-python-1.9.2-129.el6_5.4.x86_64
ipa-server-selinux-3.0.0-37.el6.x86_64
ipa-server-3.0.0-37.el6.x86_64
libipa_hbac-1.9.2-129.el6_5.4.x86_64
ipa-client-3.0.0-37.el6.x86_64
ipa-admintools-3.0.0-37.el6.x86_64
ipa-pki-ca-theme-9.0.3-7.el6.noarch
ipa-server-trust-ad-3.0.0-37.el6.x86_64
python-iniparse-0.3.1-2.1.el6.noarch
ipa-python-3.0.0-37.el6.x86_64
ipa-pki-common-theme-9.0.3-7.el6.noarch

# rpm -qa | grep samba
samba4-winbind-4.0.0-60.el6_5.rc4.x86_64
samba4-winbind-clients-4.0.0-60.el6_5.rc4.x86_64
samba4-common-4.0.0-60.el6_5.rc4.x86_64
samba4-4.0.0-60.el6_5.rc4.x86_64
samba4-python-4.0.0-60.el6_5.rc4.x86_64
samba4-client-4.0.0-60.el6_5.rc4.x86_64
samba4-libs-4.0.0-60.el6_5.rc4.x86_64

# cat /etc/issue
Red Hat Enterprise Linux Server release 6.5 (Santiago)

Comment 2 Jeff Layton 2014-02-05 21:25:01 UTC
I think we went around this a while back and decided that the problem was in the samba4 dependencies. samba4 folks, do you recall what the resolution to this was?

Comment 3 Dmitri Pal 2014-02-05 22:27:24 UTC
This is a doc issue.

Comment 4 Deon Ballard 2014-02-06 23:44:25 UTC
This is an issue with the trust packages. They conflict with Samba3, which is why Samba4 must be installed first. The note in step 2[1] does say that the Samba3 packages should be removed, which allows the updated cifs packages (and Samba4) to be installed.


[1] https://access.redhat.com/site/documentation/en-US/Red_Hat_Enterprise_Linux/6/html/Identity_Management_Guide/trust-diff-dns-domains.html

Comment 5 Deon Ballard 2014-02-06 23:52:46 UTC
The note says it, but it should be explicit that the Samba3 packages need to be removed. I have added a step to remove them to the trust setup procedure. It'll be live tomorrow.


Note You need to log in before you can comment on or make changes to this bug.