Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1061785 - gnome-settings-daemon smartcard plugin stops listening for events at the first sign of trouble [NEEDINFO]
Summary: gnome-settings-daemon smartcard plugin stops listening for events at the firs...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gnome-settings-daemon
Version: 7.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Rui Matos
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-05 15:57 UTC by Ray Strode [halfline]
Modified: 2017-07-03 15:05 UTC (History)
4 users (show)

Fixed In Version: gnome-settings-daemon-3.8.6.1-8.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-13 12:49:44 UTC
ohudlick: needinfo? (rstrode)


Attachments (Terms of Use)

Description Ray Strode [halfline] 2014-02-05 15:57:51 UTC
A customer currently has RHEL 6 NetiD smartcards, successfully.  In preparation for RHEL 7, they are testing the beta in house. They've hit an interoperability issue.  The problem is if the smartcard is inserted at login, NSS returns a spurious error.  If that error gets gets ignored, then everything works.  In RHEL 6, the smartcard code retries on error.  In RHEL 7, it gives up.

We should try to keep parity with RHEL 6, to keep this class of hardware functioning.

Comment 1 Ray Strode [halfline] 2014-02-05 15:59:34 UTC
comment 0 should say "currently has RHEL 6 deployed using NetiD smartcards"

Comment 2 Ray Strode [halfline] 2014-02-05 16:11:34 UTC
see bug 1061799 for the NSS side of this issue.

Comment 5 Ludek Smid 2014-06-13 12:49:44 UTC
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.


Note You need to log in before you can comment on or make changes to this bug.