Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1061727 - [engine] Audit log event for failure to commit network changes appears as INFO messages
Summary: [engine] Audit log event for failure to commit network changes appears as INF...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-core
Version: 3.4
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.4.0
Assignee: Moti Asayag
QA Contact: Martin Pavlik
URL:
Whiteboard: network
Depends On: 1066953
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-05 14:00 UTC by Gadi Ickowicz
Modified: 2014-08-22 01:42 UTC (History)
8 users (show)

Fixed In Version: ovirt-3.4.0-beta3
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-31 12:26:01 UTC
oVirt Team: ---


Attachments (Terms of Use)
engine log (deleted)
2014-02-05 14:00 UTC, Gadi Ickowicz
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 24237 None None None Never

Description Gadi Ickowicz 2014-02-05 14:00:11 UTC
Created attachment 859669 [details]
engine log

Description of problem:
Failure to commit network changes to host appears as an INFO message/event in the engine log. It should be an ERROR or WARNING:

2014-02-05 14:19:35,008 INFO  [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (org.ovirt.thread.pool-6-thread-26) [7cb98534] Correlation ID: 7cb98534, Call Stack: null, Custom Event ID: -1, Message: Failed to commit network changes on gold-vdsd.qa.lab.tlv.redhat.com


Version-Release number of selected component (if applicable):
ovirt-engine-3.4.0-0.5.beta1.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1 DC, 1 Cluster, 1 Host
1. Block communications between host and engine.
2. Trigger network configuration change from engine / UI

Actual results:
Message appears in log and in UI as event with INFO level

Expected results:
Should be a warning or error level event

Additional info:

Comment 1 Sandro Bonazzola 2014-02-19 12:27:14 UTC
This bug is referenced in ovirt-engine-3.4.0-beta3 logs. Moving to ON_QA

Comment 2 Martin Pavlik 2014-03-04 14:13:38 UTC
Moti,

could you please look into the code and tell me how to achieve displaying of this error? 

simply blocking traffic by iptables does not do the trick
nor does corrupting ifcfg files or manginling with their permissions
nor does vdsm restart during the change being applied

Comment 3 Moti Asayag 2014-03-04 14:54:06 UTC
You can modify the vdsm on the tested host by editing 

/usr/share/vdsm/configNetwork.py

and adding to setSafeNetworkConfig() method the last line as below:

def setSafeNetworkConfig():
    ...
    raise ConfigNetworkError(ne.ERR_LOST_CONNECTION, 'connectivity check failed')

after saving the file, make sure to restart the supervdsmd service:
service supervdsmd stop && service vdsmd restart

Comment 4 Martin Pavlik 2014-03-05 08:28:20 UTC
it seems that patch did not make it to av2

message is still marked as INFO

Comment 5 Martin Pavlik 2014-03-05 08:45:53 UTC
moving to verified (av2), since this BZ was about icon which is shown in GUI (red cross instead of green tick) 

the confusion araised from the engine.log message marked as info

Comment 6 Sandro Bonazzola 2014-03-31 12:26:01 UTC
this is an automated message: moving to Closed CURRENT RELEASE since oVirt 3.4.0 has been released


Note You need to log in before you can comment on or make changes to this bug.